Sc2 wont launch right away,long loading bar

whenever i boot up starcraft 2 from the blizzard app it doesnt boot up right away like it always did but instead the loading bar pops up and it just sits there ands loads for like 5-10mins and then the game comes up but it was always instant before whats going on? tried many fixes,i googled it as well im not alone either
anyone have this and know how to fix it?
i posted this in general but i got no response but its also in the wrong section it should be here so ill post it here as well hopefully some one will respond to me about this

7 Likes

I got the smae issue. I wanted to play some today and I keep getting this annoying loading screen and nothing happens :frowning:

1 Like

yep just got the same dam issue today looking for a fix!

Same. Tried repair, reinstall, deleted blizzard agent. It just sits in the loading state for ages…

In another topic on a similar issue a player added the game ports manually to the router. Please do check your network configuration to find any issues with your firewall, router, or port settings, as they could be blocking the game from making a connection.

There’s no updates on the situation that causes this though right now.

just uninstall Nvidia GeForce Experience solve the problem for me.

still, I don’t understand why it happen.

another solution solve the problem

  • Close Blizzard processes.
  1. Press Ctrl + Shift + Esc to bring up the Task Manager.
  2. Click the Processes tab.
  3. Select all Agent, Blizzard, and game processes, and click End Process.
  • Navigate to the folder containing the Battle.net directory:
  1. Press Windows key + R to open the Run dialogue.
  2. Type *C:\ProgramData* into the Open field and press Enter :
  • Delete the Battle.net folder.
  • Run the Blizzard Battle.net desktop app and update the game to see if the issue persists.

I have the same issue. It is brand new install but SC2 is not opening. It shows a blank popup with a loading bar stuck on loop.

I have no custom port settings in my router. Also I deleted C:\ProgramData\Battle.net but nothing changed.

Geforce Experience had no effect either.

Any Blizzard response on this? This has been going on for months

Same here for me. As I read and tried a solution with a temporary network disconnect when starting the game, I am suspecting that the start-up process is somehow unable to reach a certain enpoint or something.
This maybe an issue with the firewall, but also disabling the windows firewall did not solve anything.

Have the same issue since today… Not sure why this happens… Never had issues before.

Experiencing this now. Tried disconnecting from the internet before launching and the game launches right away. However, this is just a workaround and not really a fix. Because of this though, it does seem to be a network issue.

I copied this solution from a suggestion in our local SC2 group from someone who’s been experiencing the same thing.

I’ve already tried repairing, reinstalling, running as administrator, checking firewall settings.

happend when re-installed the game, added exception to firewall and that worked for me once and then the issue returned

Same for me! Any updates?

Well its still happening as of now. Did not play for a month or so and just want to play again.

Same here. It just keeps loading …

I have the exact same issue. Tried reinstalling both battlenet and sc2 to no avail.

I found the solution, when the loading bars appear after clicking Play just open CMD and type these in : ipconfig /release & ping -n 2 127.0.0.1 & ipconfig /renew

Credit to : TheG - Posted Solution

14 Likes

This actually works. Thank you for the quick fix.

I hope Blizzard will fix this issue at it seems to be a server authentication issue on their end. It is really disappointing that it has not been fixed yet, especially for us consumers who are supporting them by purchasing their games. I just want to play the Single Player Campaign and yet have to go through all these hassles. It’s really extremely disappointing from a consumer standpoint.

1 Like

Yeah had the same issue but the command above solved the problem for windows. Very sad that this is not sorted yet from the Blizzard’s side.