Sc2 wont update or install

Hello all,

ever since the latest patch i can not update the game, keeps saying about needing to run as administrator ( never had to do this before ) so i did run the app as admin but kept on saying the same thing.

its been 2 days now, after trying to trouble shoot the issue, i found no hope so i uninstalled the game to do a clean install but even now the game will not install.

any help would be greatly appreciated.

same problem no response tried everything

hey mate, delete your sc2 folder and try again, it worked.

That’s pretty drastic. Anyone got something less destructive than installing from scratch? That will take all night.

1 Like

Trying to install from scratch doesn’t even work, it just refuses to install the game. Renaming or trying to install to a different folder/drive also doesn’t seem to work. Running BattleNet as an admin.

EDIT: Renaming your SC2 folder in “C:\Users\Name\Documents\StarCraft II” To something else allows you to update/install. Just make sure to backup your replays and hotkeys.

Replays can never be restored without recreating the problem, but you can still watch and share them if you launch them outside of SC2. Hotkeys and Variables profiles can be restored without any problems.

You will still have a problem with renaming or deleting new replays that are created when you play, this can be resolved by taking control of the replays folder. https://www.laptopmag.com/articles/take-ownership-folder-windows-10-using-file-explorer

Huge mess fixing something that shouldn’t be a problem in the first place. Goodluck.

3 Likes

I had trouble with my SC2 installation and moved it to a SSHD because support suggested so.
But every time now that I close SC2 I get one of these windows security warning where I have to press yes or no…

It seems to update SC2 every time I played the campaign, thus this warning

1 Like

Hey there folks,

We’re tracking an issue with the Battle.net app at the moment which your reports appear to fall within. The Battle.net Dev team are working on the issue at the moment.

While this post is in the US and on the World of Warcraft forums, it will most likely get updated before I get back around here so is worth keeping an eye on.

I’ll update this thread as soon as there is new information available.

^Trib

I backed evrything up and uninstalled, but then reinstalling the install process hangs. Totally screwed now.

You say the stuff stored in Documents is the cause? Sadly I have to reinstall now anyway, but I’ll try renaming that stuff.

My gameplay hesitates and then screen goes to black. I can hear the music in the background, but can’t see anything. Can’t even get back to desktop. Tried updating all video card drivers. Still no luck. Anybody else having similar issues?

I have solved this on my computer.

problem facing: I can not update and it keeps asking me to lanch as administer. Then I delete SC2, can not install it. It keeps circling.

slove: I change the folder name “StarCraft II” to “StarCraft II1” in C:\Users\Name\Documents\StarCraft II( just to rename it). Then install it and succeed.

Thank you Ronski!

1 Like

Ronski you chad, I’ve been fighting this for 3 days (to a starcraft player this would seem like aeons) due to the permission change issue. this seems to work, I just need to readd my hotkeys etc but at least it is playable… thank you. Any interest working with Blizzard because apparently you solved something that a blue user couldn’t through an occam’s razor.

Kind regards
Simkin

Edit: btw ladies and gents, I’m afraid you can’t copy your old profile back in using this method. This will cause the issue to happen again.

I ended up discovering this myself after trying everything. Yep, the problem is a corrupted/locked file in the personal documents folder…

C:\Users(me)\Documents\StarCraft II\Accounts

I moved the folder, reinstalled (took all night), logged in (do that first), and then carefully copied back settings and replays that were not there. That folder is huge btw, if you go all the way back to WOL. Expect to take an hour of fiddling about.

The game now updates cleany.

yours, Marcus

1 Like

Marcus, you are the man! Fixing C:\Users(me)\Documents\StarCraft II\Accounts worked for me. Glad I came here before uninstalling the entire shit, reinstalling only to find the problem persist.

Thank you so much.

I keept getting error BLZBNTAGT0000084B when trying to update for a few days. After uninstalling the game, I am also receiving this error (regardless of target folder), so I can’t reinstall it now either. Haven’t had this issue before, haven’t changed any rights and do have full admin access to pc.
I’ve uninstalled battle.net and all the blizzard folders (btw Y U spam the system with folders everywhere blizzerd?), uninstalled Hearthstone and reinstalled it just fine, so it’s specifically SC2 problem for some reason.

Good day.
It is enough to give users rights to the StarCraft II folder located in the user’s profile documents “C:\Users\Name\Documents\StarCraft II”. Personally, I gave full access to my PC users. It helped me.
Reinstalling the game or uninstalling it is unnecessary.
I’m sorry, but English is not my first language.

this worked, jeebus this is so dumb, blizz shats folders on your system that you need to manually search for and it breaks access to folders, which you have to manually fix for every subfolder, because the “inherit permissions” isn’t working - it just shows an denied error.

The problem still there.
Tryed to install game after long break, not working in a single way.
Ironic kind of situation, decided to get back to play and yet something with those problems poping tells me to go away.

They broke this legendary game completely, unfortunately.

Hey there DKNxSool,

As far as I am aware, the issue that was originally behind this problem last week was fixed so you might be running into a different issue. Please try the troubleshooting on this support article and create a new topic if you continue to have issues.

i had the same issue.

in my case, for some reason, i was no longer the owner of the starcraft II folder from the documents folder, and not even admin had modify rigths

The only way for me to fix it was to make my self owner of the folder and give the administrators group the correct permissions.