StarCraft encountered bad game data

Hello there i have played SC:remasterd later today untill that error come up and i can’t fix it. "StarCraft encountered bad game data that must be repaired . " . I did run repair and also try this that found on some topic:
" 1. Press windows key + R > Type %programdata% > Click OK > Delete the and Blizzard Entertainment folders
2. Press windows key + R > Type %appdata% > Click OK > Delete the folder
3. Press windows key + R > Type %localappdata% > Click OK > Delete the and Blizzard Entertainment folders

Once done start up the App again and try to Repair the game once more. This should fix your issue."

But still error is poping up again.


Those are some of the first steps, sorry to hear they didn’t work.

Can you try the following ideas then for me now:

Let us know how it goes.

Hi, I have just hit this problem today, been playing without problems for the last couple of months, working my way back through all the scenario’s and just today I started Starcraft from the battlenet app and towards the end of the screen splash during loading it just hiccupped on the sound and then dropped the load closed the screen and left a screen pop " StarCraft is missing game data and cannot start. Try reinstalling the game.". Initially I just tried the repair option but after the repair attempting the Play I get anmother pop up stating “StarCraft encountered bad game data that must be repaired. Please run the Blizzard app to repair the game. If the problem persists, try reinstalling the game.”. The app then started “Scanning”, at 99% it asked if it could modify the files (UAC) and then started Updating and finally returned to the Play option which after clicking tries to launch but takes me back to the original symptom. I then tired the uninstall and reinstall but this did not change the symptoms other than I get the introductory Blizzard splash then the first initial video before the loading screen.
Really appreciate some help with trying to get StarCarft remastered working once more, without losing all my personal data.


1 Like

Hola, tengo el mismo problema aparece el mensaje de error “Starcraft no cuenta con algunos datos del juego y no puede iniciarse, prueba reinstalando el juego” esto ya li hice 5 veces, he reparado como 10 veces el juego, desinstale la aplicación de Blizzard etc, lo más extraño es que en ocasiones carga el video de introducción pero inmediatamente envia el mismo error, no sé si fué por haber comprado la version cartoon del juego, esperamos soluciones pronto o que regresen a una versión actualización anterior, muchas gracias.

Pleased to report that today battlenet app did an update and running StarCarft remastered works once again, the new version running is


1 Like

That’s good to know then solnarch, if anyone else still has the problem please let us know.

I received the following error message on 6/24/21. “Starcraft encountered bad game data that must be repaired. Please run the Blizzard app to repair the game. If the problem persists, try reinstalling the game.”

Well, I tried repairing it multiply times and I also reinstalled the game. Still receiving the same error.

Encounter “bad game data” error a month or so back. I waited a few days and tried again. New update downloaded and problem was fixed. Have been playing a few times a week since then. Played yesterday. I loaded today (6/24/21) and noticed an update downloaded. Same problem again. Repaired, uninstalled StarCraft Remastered, uninstalled Made sure all folders were deleted. Reinstalled. Logged in on same machine with another administrator account - no luck.

1 Like

I’m getting the same problem too, after the update today


Hola yo tambien despues de la actualizacion del 24 junio 2021 abria el juego pero no reconocia los mapas, lo desintale y volvi a instalar y ahora me sale este error “starcraft is missing game data and cannot start” , espero que reparen ese error…gracias antemano :frowning: ( el problema comenzo despues de esta ultima actualizacion en starcraft brood war)


You’ve done it again, I had this problem 17 days ago and you fixed a day later but now the problem is back after today’s update to It is frustrating not knowiong what is causing the problem, i.e. something wrong on my system or something no longer really supported but made worse by fact that repair and reinstall don’t help, just waste time :frowning:

1 Like

I have same problem since yesterday…!!!


I have same problem since yesterday…!!!

I have same problem since yesterday, please help

Buenas noches despues de esta ultima actualizacion 24 junio 2021 en star craft “Brood war” el juego no reconocia los mapas entonces desintale el juego y volvi a instalar, ahora no abre el juego y me pide reparar pero sigue igual diciendo este mensaje " starcraft is missing game data and cannot start", espero que me ayuden gracias antemano

1 Like

Hi all,

Thanks for the fresh reports!

We had to revert a recent update and things should be working again now. If you’re still having issues, try changing the language to English for now and give it another try.

Hi Blizzard… after this last update problems that occoured on youre previous updates is again an issue… 4 of my friends cant even start starcraft they have error msg same as other players wrote here… bad game data…

My issues is im having some weird chinese text box poping up in like 5 or 10 min intervals pretty annoying. My autoscroll function is not working, i need to scroll everytime new text is added frustrating… When i try to message some players on my battlenet app SC crash im not sure youre aware of this issue. Last but not least im a map maker for SC and Scmdraft2 cannot start after this latest patch when you reverted it is was ok again this problem came one month ago when you made patch there than you reverted it and Scmdraft working again. This new patch makes all these issues real again please revert the patch. So i can work on my map making

игра так и не заработала, папку battle…net удалял, игру переустанавливал, язык менял. После переустановки все равно встает версия что делать? когда заработает?

Sorry but the patch kit is still returning missing game data … and appears to be same version that created the problem yesterday and as my language is already set to English I don’t see how that helps ?

that was what i wrote too