StarCraft encountered bad game data

2 days have passed with no solution yet.

one part of the software declares every file is intact but other part of the very same software declares bad data. and the error message does not specify which file inherits this data so that we can find and fix it. this is the most annoying type of malfunction i have ever seen.

Changing language to english fixed that issue for me (was Polish before)

1 Like

изменил регион, после программа предложила обновление обратно до и всё заработало

At USA forum they recommended selecting region as asia. The trick is, asia region has not not been upgraded yet. you can use previous version there.

I worked on it and here is the “safe” procedure you must follow:

  1. restart computer.
  2. start battlenet application
  3. uninstall starcraft via battlenet application.
  4. close battlenet app
  5. restart computer and open battlenet app.
  6. select region as “Asia” from left bottom.
  7. restart battlenet and check if the region is selected correctly)
  8. install starcraft via battlenet app. (DONT INSTALL UNLESS YOU SELECT YOUR REGION AS ASIA)
  9. after installation is completed, check bottom left for version. it must be as “region:Asia version:”
  10. start game, there may some chinese/korean popups, dont bother…
  11. you may asked for password in game. dont panic, reenter your mail and password
  12. have fun. i have experienced no lag so far. see you there guys :slight_smile:
  • ranianfelix2 -

The game stil won’t launch :frowning:

Hola, pudiste resolver el problema?

hm, after change language problem with “StarCraft encountered bad game data” missed, but when i launch the game it crashed immediately. GJ blizzard, it stopped me from buying remastered version.

yeah well id rather blizzard to work and update SC than blizzard not doin anything towards improving SC… when they make faults they will ofcourse fix the bad things they made everything else would be stupid from blizzard side… Swarty you not buying SC Remaster for this reason i dont understand… The graphip and fullscreen of Remaster is 100% worth it and you prolly been playing SC for so long that contributing 10 dollars to blizzard for this update is nothing.


Been experimenting and found that changing the language from English to French, doing an update and trying to run game failed as expected, then reset language to English and updated and this still failed - so I don’t think language is the prime problem.

I also tried simply changing region from Europe to Asia and updating, reset the installed image to and simply launching the program worked just fine (no uninstall re-install required - anyway working again but not sure how long before Blizzard update Asia :frowning:

As i have explicitly mentioned at the previous post, the procedure i have recommended is a “safe” one. If you dont uninstall first, endless update loops may occur or other kind of conflicts may appear.

Tengo el mismo problema, por favor arreglen en cuanto se puedaa

Many thanks! It works! Why doesn’t official technical support make such recommendations? All they told me was to try installing the game on a different media. And if this does not help, then contact the forum.
But I first turned to the forum =)

Yo lo arreglé cambiando a 32 bits en las opciones. :nerd_face:


hola, yo realize los pasos que indican en el foro y las soluciones que ud brinda pero aun asi no me ha funcionado sigo teniendo el problema no puedo abrir el juego

yo lo cambie a 32 bits pero aun sigue sin funcionar

I did everything including reinstalling the game.

Still can’t play. Game launches non remastered version then crashes.

At least before we could play the game…

Blizzard - when will you be fixing this problem - you have fixed it before within 24 hours so why is it taking so long now ? And why are you not supplying updates on what is cause of problem and when you think a fix might be available? Also can we have an official position about what workarounds are safe to use ?

pudiste solucionarlo? me ocurre lo mismo y.y

Me ocurre lo mismo trato de instalarlo y me sale ese error ojalá lo reparen pronto TwT al menos antes del 11