Starcraft II uses my Microphone

As I opened my game after some 250-ish update 11 April 2021, I see in my toolbar that StarCraft 2 (not battle.net) is using my microphone. Whats up with that?

SC2 has an ingame Voice Chat, so that would be while it’s using the Microphone, you can disable this in the Settings menu ingame.

Even if the voice chat is disabled from ingame, SC2 is still using the microphone. Besides the fact that this is creepy it is also messing up bluetooth headphones profiles (goes into headset mode) and the sound quality is terrible. The only workaround for this is to disable the microphone permission for all apps (you can’t for individual apps) from Windows10 before launching SC2 and you have to do it everytime you start SC2 which is annoying. Are there more permanent workarounds for this? E.g some file settings that can be modified.

Some Antivirus software can perform this specific mic to app block, HOWEVER, I advise to wait for an Official Blizzard Representative to write us whether we are allowed to use 3rd party tools in order to perform this block (?) . So blues, are we allowed ?

I’m curious about this as well. Having the same issue with Bluetooth profiles. The sound quality is terrible because the headset goes into headset mode.

Any way to disable it completely? Using CLI parameter like --disable-microphone?

EDIT: Found that you can change the default device for a running application:

  1. Settings
  2. Sound
  3. App volume device preferences (Advanced sound settings)
  4. Change the Input device for StarCraft II

Change it to another input device that isn’t your Bluetooth device.

Any variation of this should work. You can change the default input device in the options menu in StarCraft II. Or you can change the default input through the Battle.net launcher.

1 Like

Definitely messes with my Jabra Evolve 75 uc connecting the microphone even though I have it disabled in talking, I have to enable and re-disable talking each time I start the game, it doesn’t check the setting before taking ownership of the microphone.

Agreed, this is super annoying. I came back to the game after years of not playing and I’m greeted by this crappy bug. SC2 shouldn’t be trying to access the mic if I’ve disabled the voice chat. On top of that, it doesn’t respect the sound devices chosen in Windows or the ones chosen in the game. I tried the suggestion above to change the defaults both in game and in Windows and none worked. In the end I had to disable the “hands free” mode of my bluetooth headphones to stop SC2 connecting to it. It seems this was because this mode was marked as the Default comms device in Windows.

Basically the bug here is that SC2 tries to connect to the mic even though it’s been explicitly told not too. It’s super confusing because I don’t even have Voice Chat option in my game options anymore so it’s not obvious why it’s doing it either.

Please fix this bug.

1 Like

Has anyone found a fix for this by chance? I’m still having trouble and it’s super annoying. I have only found a fix by going into my Windows privacy and security settings and under Microphone, disable the ability of desktop apps to use my mix. However I don’t want to do this because I use my mic with other apps all of the time. The only app I am having trouble with is Starcraft 2 and when I try to disable the mic in the game settings, it doesn’t fix the problem. Super frustrating.

hi Blizzard, please fix this issue :)! I have been googling and looking for a solution, and there are threads on this very issue from 2018! stop connecting SC2 to microphones and headsets, it doesn’t do any good and it breaks bluetooth headsets!

The workaround is to connect your headphones after you launched SC2. It seems that they do not care about us enough to fix this bug which is a violation of our privacy (I disabled voice chat and it is still enabled).

1 Like

Children play this game which makes this a clear violation of COPPA. Note, it does not matter whether or not the game is marketed to children.

Considering this appears to date back to at least 2018 I suspect there is a real problem here.

While I can’t post links, for precedent search “FTC FORTNITE COPPA”

Blizzard should really re-consider neglecting this thread.

1 Like

Hello together… this is so crazy. i cant disable voicechat, even if i disabled it in the privacy settings. Why did they disable it in the options? I cant even change the device. I’ve never seen anything like this. it feels like some sort of a scam or privacy violation. i cant do anything, my webcam with voice integration is always on when starcraft2 starts. What the **** ?