Starcraft remastered on new MacBook M1

Just got my new MacBook Pro M1 and the installation works fine but the game doesn’t start. It crashes instantly. Any chance for an update in the future? The same goes for Warcraft 3 by the way…


There does seem to be some issues with the new Macs that are being investigated and worked on, however I did find this post from our Mac forums for SC2 (which should also apply to SC:RE and WC3:RE for now):

So you need to find the WC3:Reforged and SC:Remastered settings in your Library and see if adjusting this line works.

Thank you! I don’t have any Starcraft or WC3 folders in the Application Support folder. I can only see a “”, “Starcraft II” and “Telemetry”. Where can I find the variables for SC and WC3?

1 Like

There might be something else we can try. If you set Starcraft to start with Rosetta:

It might work with that.

SC still won’t start, but WC3 finally works!


With my m1 MacBook Air I am also suffering from SC:RE crashing on start


The “Open in Rosetta” option doesn’t show up in the app info.

1 Like

Thats because that particular option only shows up with universal apps, for intel and apple silicon

Hi I have the same issue with SC Remastered on my new Apple MacBook Air with M1 :frowning: Are there any news from the engineering team regarding the fix? Thanks


Does anyone find out the solution to fix SC Remastered with M1 chip ? :frowning: So boring without games :frowning:

1 Like

Same issue here with my M1 Mac Mini. Any news?

1 Like

No news (other than what I previously posted), though the discussion is still also happening on the US forums for Mac Users:

You can also post there and add your voices to the thread on the front page.

1 Like

Do you have an ETA for this or it’s just not going to happen?

Thank you very much


Any news ? I have the m1 too and still doesent work to lunch the program.


Have we had any update? Desperate to play it but it crashes instantly on launch!


Dear Blizzard,

Please update this thread!!! Work harder and finish the M1 version!!! cracks whip

Thank you

Same here, i hold my old mac with intel just fo sake of playing SC remastered. What a crap…


Please do help to reply and fix this asap! I already switched my Mac to M1 chipset.
I do want to play the game with mac mini m1.

Hope developer can see it.


Just wanted to confirm that this is still an issue, but Blizzard are seemingly aware of it. There’s a good topic about this on the US SC:RM Technical Support forum here:

Application crashes immediately at startup.

I have followed a few suggestions I found on these forums and elsewhere to get this to work.

  • I tried renaming my Mac to a simple single word with no special characters - no effect, still crashing on startup.
  • I lowered my screen resolution, no effect.
  • I attempted to disable vsync following instructions online, however it seems like the instructions were written for Starcraft 2 and don’t apply to Starcraft Remastered, and so I was unable to perform the “fix”.

Hoping that Blizzard notices this and gets it fixed - it’s the only application I have that doesn’t run flawlessly on the M1.

For Blizzard devs, I’ve included the stack trace for the crash below. I hope that this is helpful.


So what’s goin on wit M1 patch? Game still have Apple logo.