Starcraft2 won't start after win10 update

Since updating windows 10,game does not load. Error graphics device is not available at this time.

i have installed latest graphics driver and restarted windows, but stll does not work.
NVidia Ge Force GTX1060 6gb graphics card 2560x1440 on samsung 2k 27inch curved monitor??

Having the same issue here.

Hello,

Please try the additional steps from this article here.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki

tried it, didn’t work.

1 Like

Hello again,

Did you try the steps specific for this error as well?

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki

also tried, with no luck

Could you please post a DXDiag and MSInfo here? If the data is too big to be posted on the forum directly, you can use a page like pastebin.com and post the link to it here then.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki

I would if paste bin would let me insert file and screenshot

OS Name Microsoft Windows 10 Pro
Version 10.0.18362 Build 18362
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name HOME
System Manufacturer Gigabyte Technology Co., Ltd.
System Model To be filled by O.E.M.
System Type x64-based PC
System SKU To be filled by O.E.M.
Processor Intel® Core™ i7-3770K CPU @ 3.50GHz, 3901 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F13, 19/09/2012
SMBIOS Version 2.7
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product Z77M-D3H
BaseBoard Version x.x
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United Kingdom
Hardware Abstraction Layer Version = “10.0.18362.267”
Username HOME\Nigel
Time Zone GMT Summer Time
Installed Physical Memory (RAM) 6.00 GB
Total Physical Memory 5.96 GB
Available Physical Memory 1.37 GB
Total Virtual Memory 13.0 GB
Available Virtual Memory 5.00 GB
Page File Space 7.03 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualisation-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and the device is not Modern Standby, Un-allowed DMA-capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware No
Hyper-V - Data Execution Protection Yes

Good morning,

If you can’t get the files uploaded, I’d suggest to open a ticket and attach those to it.

Kind regards


What’s your opinion?

https://www.surveymonkey.com/r/Kiemmaki

I also have same issue. I assume the recent Windows 10 updates AFFECTED something. Only SC2 doesn’t work. (Have tried to launch Hearthstone and Overwatch from my side, they worked well.)

Please figure it out and hopefully fix the issue!

Same issue here.
I have all but WoW installed, everything is playable, yet SC2 launches, spends few seconds in the black screen with flickering cursor and crashes with the “Graphic device not available”, which clearly is available.

Same Issue here,
Looks like a common thing now doesn’t it

I also did all the fixes on the support site with no luck. has anyone got a fix been down now for 4 days!!!

Has there been any update on this as I’ve been unable to log in for 4 days now too. What I get is when I click play the game loads and after a few seconds on the loading screen an orange window comes up saying “an error has occurred” and all my regions are blank meaning I have to quit out.

1 Like

Hi Any Joy. I am still experiencing log in issues. Well more to the point can not even get online in the game mode to play SC2. Any advice?

Same issue here. Tried everything and it doesn’t work.
Anybody managed to fix it?

I’ve not been able to fix it yet. No reply to my own post from blizzard so guess I will have to go play PUBG till someone fixes it.

I ended up having to go to the battle.net launcher-> game settings->starcraft 2 and check the “Launch 32-bit client (instead of 64-bit)” option. Pretty lame, but the only way I was able to play.

same here doesant work

same problem at my side. Is there any update of the issue?