Unable to join Custom arcade games (must upgrade your copy of SC II)

Cannot join custom games in the arcade section. Says something about “In order to access this content, you must upgrade your copy of SC II”. I do not use a free account, so this is clearly a nonsense error… have shut down, restarted, no luck.

Also, cannot create my own lobby. “There was a temporary problem with your request. Please try again later.”

Any ideas?


Only game working on the Arcade is the Direct Strike abortion.
Every other arcade we’ve tried gives “temporary error” after a while of “entering lobby”.
Most unsatisfactory on Christmas eve.

1 Like

Same here. Does anyone have a fix for this?

Same. Can’t create, auto-join or join. Just upgraded to LOTV. Is it due to this?

I ran “Scan and Repair” and now it is working. Not sure if it was just a coincidence though.

Hi guys! Sorry you’ve had this issue. There appears to be an issue with custom game lobbies, and we’re investigating. Sorry for the hassle!

Any news on this? it’s been seven hours now?

No updates to share as of yet we’re afraid, if there are any we can share we will update you.

Same in Sweden i been trying all day in different locations and different machines … :thinking:


problem still persists. many maps and many players are affected. sorry to interfere during the holidays, but a word still would be nice. thanks, guys

Updates in one place an option? Can you open a special forum message or place a news item on the website, so we don’t need to search for answers everywhere?

Updates in one place an option? Can you open a special forum message or place a news item on the website?

Still blocked (04/01/2021)

PS : To me, if some specific arcade games and mods can be played, and some not, maybe it’s because they are regularly updated, and maybe, as they updated the AI, it’s that kind of incompatibilities ?

(Better try to help while waiting ^^)

8 posts were merged into an existing topic: [Main Thread] Temporary Request Error - Jan 2024