9.2 and the keybinds issue

I dont understand what is happening at blizzard at this point but this just seems ridiculous to me its almost just a comedy at this point.
My hype for 9.2 had me with so much hope that i decided that i would stop exp with a character at level 45 and gear that character up in full gemmed gear and do all the quests in all the old zones and i mean every zone that i could do, and just maybe do some random BG and mog farming here and there on my level 60 characters and and a few timewalking for some welfare gear, not really do anything end game related.
why? i still like warcraft and think its a great game to waste my time in.
And i said to myself that blizzard could screw up 9.2 how ever they can and it would not really bother me that much.
So what does blizzard do then? screw up my keybinds cuz i dont use a english only keyboard.


Blizzard has turned into the south park version of blizz at this point.

1 Like

Yeah I’m running into this as well. WTF is this about?!

½ is \
+ is =
å is [
ø is ’

That was the stacked double S for me.

On my end I have no clue what key have become +, but | is now \.

Same here. Went into the keybind/actionbar options and changed it to /. Works now. I’m a happy pupper.

Well, I’m glad it’s gotten to work of course, but I won’t describe myself as happy. Several of my binds have the wrong label on them now. Not really a big deal but I just don’t get it. Why mess with it? WoW’s keyboarding system was so good and so ahead of it’s time in 2004 that even today, 17 years later, it was still best in business. And now they’re messing with it.

They are aware of the issue, this is from the Technical Support forum:-


It seems that the keyboard layout for hotkeys was changed to English with patch 9.2, so if you have another language selected for your keyboard some hotkeys will not be recognized. Your language layout should work normally in chat, only hotkeys are affected. We are investigating this at the moment and it should be fixed soon.

Background software for keyboards, addons and settings in WoW do not appear to be responsible for this. The only temporary workaround is to open the keybindings in WoW and set the same key you used before again as Key 2. This will allow you to use the same hotkeys as before and can be reverted once the issue is resolved.


Me neither. I change my mind, I’m not happy with this at all :sweat::confounded:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.