Battle net Launcher Dead : Blizzard Agent went to sleep. Attempting to wake it up

As the title says, i can’t log on the battle net launcher anymore.

No matter how many time i kill the process, i just end up with the “Blizzard Agent went to sleep. Attempting to wake it up …” error and a link to a very helpful " Something went wrong on our end. An error has occurred. This may be a temporary error, so please try again later." support page.

If just like me you can’t access the launcher don’t worry, you can still play by using the wow app in your wow > _retail folder.

Edit : Just realised that i’m stupid. There’s a whole forum filled with this kind of post. Kinda forgot that GD wasn’t the only wow forum


same problem… been like this for 3 hours now… cant log in … its friday.:((


I have the same problem except I can’t play anything. I don’t play retail but classic, and when I launch without, all realms are incompatible…

Thank you for the tip. Starting the app worked fine… :slight_smile:

go to wow folder use wow exe and log in manually.

works 9/10 times


Guess i’m that 1/10 then, I manage to log in but only see US servers etc. Anyway to change that without the launcher?

This is why I love the forums! Thank you!

We are aware of this issue and are working to resolve it.
You can keep updated on known issues over on the CS EU Twitter.


Thank you!
Hopefully it gets resolved soon :slight_smile:

Friday and was about to have a good time when my app refuse to wake up :frowning:

Hopefully it will get solved soon.

I can’t access any games at all.

1 Like

you are the man!!!

Using the .exe file worked fine for me. It asked for autentication though, never need that when I use the launcher.


I have the exact same problem.
Tried everything. Reinstalled everything, restarted everything. Cleared all sorts of caches.

So yeah, hopefully they will fix it soon.

Remember - Most games can be started without the launcher from the folders. like wow.exe.

1 Like

Haha guess what. I paid my subscription today after 5 months of not playing knowing I will have the time to actually play now.
Guess not.

The world hates me. </3

Looks like it’s fixed :)!


My issue was strangely with my ISP. I just tethered my line from my phone(different isp) and it worked(private vpn like hotspot sheild may or may not work). Previously things that dint work but executable in this order

  1. Uninstall battlenet, kill agent.exe and battlenet from task manager
  2. Make sure all you windows updates are done.
  3. Clear battlenet and blizzard from appdata folder
  4. Clear battlenet and blizzard from local folder
  5. Clear battlenet and blizzard from program folder
  6. Install fresh latest battlenet
  7. Add exception to firewall

If after all the above it doesnt work then change the ISP mentioned in the beginning of my brief

If this helped you 0x3a4FeC5ac612DA1B71Dd21317178e6DaC612De24 eth gratitude

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.