Bug - Can't create group in finder for Murozond's Rise without authenticator

One or more dungeons was not valid
all the characters who got the “Galacrond’s Fall” key missed the opportunity to level up the key. It’s terrible because this key drops out every week on several of my characters. if you don’t have a permanent group, then you’re just stuck :face_with_diagonal_mouth:

1 Like

I get this error every time I try to list my key (Galakrond’s Fall)

Seems that this is also happening on US too - https://us.forums.blizzard.com/en/wow/t/one-or-more-dungeons-was-not-valid/1718290/7

1 Like

I’m getting this, too. I cannot put my Fall key up.

Getting the same issue here; its very annoying, please fix the issue!

Same problem here. Cant push my key this week :confused: very anoying

Had this issue, I picked the dungeon manually from the list and it worked.

1 Like

I have the same problem too pls fix it.

And bigest issue is if you dont have autenticator so you cant do it manualy

I have the same problem too dawn of the infinite: galakrond’s fall

I have the same problem. Galakrond’s Fall.

Same issue now, Galakronds Fall - “One or more dungeons was not valid.”
I got the key after swapping it.

“One of more dungeons was not valid” How in the world is this bug still in the game? Yall can get nerfs out instantly but a bug fix? never happening or what?

This bug has been in the game for TOO DAMN LONG NOW! Please FIX the damn bug already!

To those that try to defend blizz on this one… just dont yall are insane for even trying to defend this nonsense.

Did you even bother to read any of the other posts about this? I mean, there was a blue post today, on this very topic, which said a hotfix was due to be rolled out, but was found to cause other issues, so was delayed.

Thank you for showing me the way! from now on im going to dig through the entire forum for something that should have been fixed weeks ago! Im so sorry sir will never happen again!

1 Like

I got same issue . only difference now is that it`s present to all my character :sweat_smile:

So Murozond’s Rise working now but today I receive key Galakrond’s Fall fall and again cant que becouse it’s still bugged. It’s almost month and still no repair. So now I’m paying for game that I can’t play properly to next reset.

Fix on mythic + Locked Keys is to change it`s dungeon type frome NPC at the end of Dungeon.
PS: Key needs to be same lvl or lower then M+ dungeon.

Same issue here.
Galakronds Fall - “One or more dungeons was not valid” when trying to list the key.

Are you serious? I get this key from the start of the patch every week, it’s some kind of mockery! I tried not to open the vault, went to the m+ dungeon and in the end the same key fell out again :man_facepalming:

Still no fix :confused: Can’t make group, can’t get rating becouse of that and that makes things more dificult to find group to other dungeons.