Bug preventing Kultiran humans unlocking


#1

Hi,

I’m doing stormsong zone quests in order to unlock the zone achievements. The problem is for the “from the depths they come” questline. Server is Magtheridon.
Lieutenant bauer give only one quest : a bit of a bind. She doesn’t give Freedom for the sea or caught in the net. It prevent me from finishing the questline, and it’s a must-have for the zone achievement and the allied race unlock.

I have done all the prerequisite, I had the starting quest for this (all 3 actually : bauer backup and the 2 others). Another player was stuck the same way, with the NPC giving only 1 quest.

I bought a faction change in order to unlock all alliances races after unlocking all horde races. I hope this bug is resolved soon.


#2

I am also having this issue… really annoying, I’m literally 1k rep off Exalted and i’d get that from the Dungeons from Pride of Kul Tiras quest line…


#3

Just adding some extra information:

  • Clearing WTF and Cache folder does not resolve this.
  • I tried to get the quest on an Alt that had not started the Q chain and he couldn’t pick it up either.

#4

Just to confirm I’m having the exact same issue, I was only offered the “A Bit of Bind” quest too instead of all 3. Completely hit a dead end with the quest chain, ran all around the zone trying to see if completing any quests i’d missed would help, but it made no difference.

Only resubscribed to unlock and play Kul Tiran, so currently in limbo waiting for a solution.


#5

I’m having this issue too…


#6

I’m in the same boat as you guys. Checked all previous questgivers linked to Bauer but nothing. She only gave me one quest with no follow ups


#7

I guess we must wait for a hotfix. Sometimes, NPC are stuck and the server reset clean it, but wednesday is a long way from here when you have a goal in your gaming mind :slight_smile:


#8

I have the same bug right now. Finished all three of the breadcrumb quests that lead to Bauer. Killed the Sea Mistress or whatever her name is, but never got the quest to kill the 6 elemental thingies. Also looks like that bug has been around since BfAs launch. Once again, great work Blizzard! How about you fire some more of your workers. Might I suggest a large chunk of your QA next?


#9

UPDATE

She’s back on people. Maybe they fixed it, but I heavily suspect a conflicting world quest, because there was 2 in the same zone as the NPC when I tried. Anyway, she gives me the 2 missing quests now.


#10

Happy to hear that. Do let us know if you encounter any further trouble.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#11

Yes, she’s working again, must be a conflict with that world quest that was close by.

Happy unlocking people.