Can't accept or decline a forced quest

After a few years unsubbed I restarted Wow a couple of weeks ago. I entered the game with my Monk and leveled up to 70 with no issues. A few days ago I intended to level my Paladin alt as well, after upgrading the gear on the character select screen I entered the game.

On starting in Stormwind, the quest “A Brother’s Help” was opened, which I decided to ignore, so I pressed decline. After 10 secs or so, the same quest opened again, so this time I accepted. 10 secs later it popped up again. No matter if I accept or decline the quest dialog is forced open after a few seconds.

Since the the quest is auto-opened, it closes anything else open like other quests, the map, etc. That makes playing on this character unplayable.

This is on a new install of Wow on a new computer with no mods.

I opened a ticket and tried the two suggestions, delete the (no luck) and ran the /console cvar_default command in game (no luck).

Now I am out of options. Any help would be great. Thanks.

Have you tried just going to Nazmir and meeting Magni to hand it in, then not except the follow up. Might be enough to get rid of it as it shouldn’t popup after you have handed it in.

Yesterday I did try, but the Zandalar map is completely blank and I don’t have an intro quest to go there. On the forums someone suggested going to Kul Tiras and doing the campaign until it opens. But since I can’t easily use the UI without the quest dialog blocking things that seems painful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.