Can't List a Group in Group Finder for new M+ Dungeons

I can’t list a group for the “new” Shadowlands Season 4 Patch Dungeons, I tried on another character to get a key for Tazavesh, because I wanted to check if it was only a problem with the new dungeons and apparently it is, I got a Tazavesh Gambit M+ key on one of my alts and I could list that, but I can’t list Operation: Mechagon - Workshop or any of the “new” dungeons that got added with Shadowlands Season 4 Patch. Anyone got this problem as well? Tried to talk with Customer Support but apparently they can’t do anything and I gotta wait for Developers to fix this bug, so basically I can’t progress my characters in this new Season and I lose game time by not being able to do the “new” content and get better gear, great job blizzard.


I’m having the same issue!

Yeah, I’d really appreciate if you could do in-game these steps:

Game Menu (Escape)
Submit feedback or bug report

copy paste this or write something about the issue we’re having:

I’m having issues listing a group in the Group Finder, I seem unable to list a group only for the Dungeons that just recently got added in Shadowlands Season 4 Patch, I tried listing a group on my alt for Tazavesh and I could enlist it, so it’s an issue for the newly added Dungeons.

1 Like

I’m experiencing the same issue, I can get to the “Settings” screen where it selects the Keystone I have and auto fills the rest for me.
But then when I click the List Group button, it shows the Listing group… loading screen, but then just hops back to the “Settings” screen again.
It worked with the Tazavesh Keystone I got first, but it does not work with the Grimrail Depot one.

I had my friend try this and it works for him. The only difference between us is that he has connected a Mobile Authenticator and can customize the title and everything when listing a group.
Works like a charm.

Could the issue be that the new dungeons cant be listed unless you have a authenticator connected because the title of the group is not one of the predefined ones you got when the shadowlands dungeons was in rotation?


Same issue here. No authenticator and can’t list the new dungeons.

1 Like

I got the same problem, can’t make groups on any of my characters

1 Like

I have the same issue. And i have submitted a bug report. If this is not fixed withinn the next few days Season 4 can kiss my butt. And ill go think about if DF even is worth trying.

1 Like

Same issue here. Can’t play my own M+ keys…

1 Like

I have found a fix for this. Going into karazhan or mechagon instance for some weird reason let me list my key. Those are the 2 i tested, probably some other instances might work too. Hope that helps!


Yup, can confirm that this fixes it. I entered Grimrail Depot and I can list my key no problem.

Thank you, this worked for me as well and i had the same issue

This doesn’t seem to work for me anymore. Couldn’t list my Tazavesh Streets key on DH and zoning into both Gorgrond dungeons, Kara, Mechagon or Mists (as per another thread) didn’t do anything as a workaround. On all other chars i tried the listing for their keys worked (though none of those were Streets) ^^

Edit: Or this might somehow be connected to the Legion key now, DH is the only char i grabbed a Legion key on and can list that one fine, just not Streets

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.