/cast [mod:shift] still not working

I disabled all add-ons
I made sure no other key is bound to my binding (shift-E)
I tried changing the Action bar lock to every other option
I tried changing every option in self cast options

/cast Earth Shock
/cast [mod:shift] Frost Shock

Please help!

By default, E is bound to movement - strife right so that may cause you problems.

I’m not sure what your trying to do with the Macro. Your Macro will cast Earth Shock without shift, and will try cast both if you hold shift.

I’m guessing your intention is to cast one or the other and not both? If so try this:

/cast [nomod] Earth Shock
/cast [mod:shift] Frost Shock

or a shorter version of above would be;

/cast [mod:shift] Frost Shock; Earth Shock

You should’nt need the #showtooltip.


my hero, thanks a lot, your macro works!

1 Like

This is actually just down to logic. If you have something with zero conditions before something which has conditions, the second spell will never actually be actioned because the first always supersedes it.

Ráevelyn’s first solution works because they stipulated conditions on the first spell as well. The second solutions also works because the order is changed and the conditional spell comes before the open spell.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.