Character model not showing on Armory for a week

I Faction Changed one of my character a week ago and the model still not show on Armory.
/eu/tarren-mill/caoimhee

Created a new character yesterday and the model also does not show on Armory.
/eu/tarren-mill/ciaara

Faction Changed and Server Transferred another character today and I’m afraid it will be “modelless” forever like the others. (edit: and now worst, it does not show on my list of characters anymore on Armory, was showing after 30 minutes or so I did the transfer)
/eu/tarren-mill/bronaagh

Is not a big issue on Armory, but all services that use the Blizzard API to retrieve your characters show no avatar or image for the character, it includes the Blizzard companion app on mobile.

I’m having this exact same issue. I created the character a week ago and she’s nearly level 60, but still no model will load for her. The only factor was that I name changed her and I’m worried that’s why.

same issue here, realm transferred a week ago, character doesn’t show up on armory since then, I was hoping for the weekly rolling restarts to solve the problem but still nothing

I dont know should I just wait for the armory API to fix itself or is there anyway I can refresh it ?

Fix is to clear google cache and cookies +history

I’ve tried with 3 different browsers (Firefox, Chrome, Edge) on 3 different PCs (home, work and friend’s) and yielded the exact same results, so no it’s not browser’s lingering corrupted date problem or any particular PC issue, it’s blizzard armory API got corrupted during my realm transfer and I don’t know how to refresh it

Hi there Kátriona,

Thanks for the report!

Unfortunately there is no way to manually force a refresh, and it would just be a matter of waiting. For more info, check out:

That said, I can see that there are a lot of other recent reports over on the Website Bug Report forums as well so I’ll pass it along to see if there is any intervention needed.

Thanks again for reaching out and hopefully things will catch up again soon enough!

No problem waiting, but it will be that way forever? It’s more than two weeks already. I know that it isn’t an important feature of the game, but just abandon a feature that is related to API info passed to the 3rd party websites is not acceptable. Just provide a quality service for people that pay a monthly subscription to play a game and have these small website functionalities.

All my characters that got transferred and new characters I create have this problem. So I don’t think it isn’t just a cache issue on the server.

It is not related with user side, is server side, so it isn’t a solution.