Collectors Cache Not working

? Still nothing the collectors cache opens and I dont receive anything. Not my first 500 and not any of the tenders Ive earned. and I please get a response?


Same issue here, several other people have the same issue aswell.

1 Like

yep, same issue here. opened a ticket ingame and reported a bug and customer service adviced me to open a bug via ingame bugreporter … kekw. is this a joke?

There’s a difference between opening a ticket and reporting a bug. The former gets you a GM response and the latter sends it to the QA/Devs team which doesn’t get you a response.

GM’s cannot assist with the known Tender issue and doesn’t process bug reports through tickets.

same and no logging out all night did not work. Yesterday i felt sure i had gotten more than 150 on opening the chest but i had only gone up from 200 to 350. Oh well i thought i must have been mistaken.
But today I got 500 more from the chest (and i know it said 500) but i STIL only has the same 350 i had yesterday, when talking to the dwarven trader lady.
So obvious i was not wrong yesterday either. It is a coin stealing trading post.

Same issue for me…literally being ignored by GMs/Devs.

Same issue for me. Is there an update on this?

So in short they are a lot of people that cannot use this feature because their currency cannot be looted in the chest.

I think blizzard need an updated post on this bug and communicate on its resolution, especially if game masters cannot do anything about it.

1 Like

We now have a thread at the EU side:

1 Like

i tested several things like turning off all my addons , i tried it on another realm with an alt , i even reinstalled the game !! but still iam not getting credit , My journal keeps saying i must claim tender using the chest next to the trader post , so i click on the chest , it opens up then Nothing ! i did all the mini quest related to the trading post , i did fill up the bar doing the activites till it was full but still iam not getting anything when i open the chest. i just give up now

Same issue here, I did the intro quest, chest bugged but w/e I thought. Did a bunch of tasks, I filled the bar to full and it’s telling me to go to the trading post to obtain the mount, chest doesn’t give me anything (again, it never did, even during intro quest). Worst of all is that despite having filled the bar I somehow have 0 of the currency so I can’t even buy anything from the shop either.

No chest, no currency to buy anything and no mount :confused:

Also got the issue, did all the quests and tasks and can’t collect anything from the chest, it opens up but no loot shows at all.

Just adding on to give more visibility.

I have the same problem where I’ve completed the intro quest and done some progress in the log but whenever I open the cache it plays the animation/sound but nothing else happens.

Tried the UI reset that was recommended but that did not help either.

did 1000/1000 mount missing… still not fixed

1 Like

Same, also loot from progress was buggy. I see that complete some activities and can’t loot it. Some times, when switch zones or merc in BGs I see that have zero progress, while I have complete a lot.

I had 900 coins yesterday and today I have none.
Plus, I have finished the track and no mount yet.

Is that hard to fix this TP?!
Why release if it wasn’t working?!

4 Days into the feature and im still unable to acquire anything. we had 1 official response saying they are looking into it. great so far was really looking forward to the TP and thought how well Blizzard had been releasing Dragonflight so far. Guess hoping for a working feature on release is too much to ask for.

I have the exact same issue. Still 400 Traveler’s Tender sitting in the Trading Post cache. Hopefully we get to loot it before the end of the month. I tried different approaches (different characters, logging on/off, just waiting). I can only attempt to loot it once a day it seems.

For people working on the bug: I have 400 Tender waiting in the cache. If I open the cache I don’t receive the tender, but my Traveler’s Log is being updated to reflect that I have looted the cache. In fact I haven’t. I bought the mount after I got my first 1K, got another 600 somewhere and have now 400 (from completing the log) waiting in the cache. I did get my mount for completing the monthly log however as that didn’t come from the cache.

Is anyone still experiencing this problem? Came back from a month or two hiatus (burned myself out pretty hard with Dragonflight keen) and there’s some really nice items I want to pick up from this feature, but can’t seem to get it to work; I have tried all the suggested fixes too, tried on multiple characters on both factions and I’m worried I’m going to miss out as I understand these items are time-limited. Curious to know if I’m missing something or if this still hasn’t been fixed?

1 Like