Trading Post Issue and Fix Underway

We’ve identified an issue that’s preventing players from receiving Trader’s Tender and Ash’adar rewards from the Traveler’s Log.

We do not believe any credit or progress has been lost, and we believe that the expected rewards should in your Collector’s Cache once the bug is fixed.

Thank you for your patience!


The main feature of the game and (my case examples):

  1. No mount after completing Traveler’s log
  2. After logging today 0/1000 points + Trader’s Tender points go to 0 from 1600 + completed activities and no new update from Blizz what is going on
  3. Next login progress back, points back but mounts blocked (stlii no Ash’adar)
  4. Next login, again 0/1000 points in Traveler’s log.
  5. Next login, points are back. Btw the game in the char list, somehow doesn’t remember I changed my transmog yesterday.

Nice chaos for a main feature of the patch…


Mine kept resetting my progress too. Not quite got the mount unlocked yet, but I know it kept resetting the bar. My catalyst quest did it twice too! Didn’t just reset, dropped the quest twice so I had to pick it up 3 times and complete it in one go to make sure it didn’t do it again! Opened a ticket and got a generic response of ‘relog and drop quest and try again’


I still don’t know how many tenders I was supposed to get, was it 1600? 1500? 2000? :person_shrugging:


I’m showing 2K in game. I think that is the max amount this month. However my addons think I have that 6 times :smiley: 12K it is showing (pretty sure that is a bug and it is account wide)


Thank you for the info, looking forward to the fix.


I’ve had several resets of my Traders Post progress, 2 today! I have completed it all, and it says I have all for this month, but I still cannot pick up the mount.


I got nothing from my trading post “challenges”.
I completed all of them, but no reward nor mount :frowning:
In the traders post window it says i’m done, but i’m getting nothing.


Afaik you shouldn’t be able to get more than 1000 in a full month.

Edit: I made a typo again and forgot to add a specific word that changes the entire context of my comment… RIP

You get 500 just by logging each month then you can earn another 500 from task’s to fill the bar. You 100% get 1000 per month.

For other months yes but the first month we get more with the introduction quest.

Friend of mine had her progress reset when at 850, however now it says she has claimed all rewards for this month, but she never opened the chest to claim any of the milestone rewards. So if it is not fixed for her , then she will get bugger all.

Myself, I’ve got the issue where I did not get all my rewards, including the mount, after opening chest. Maybe Blizzard should change it’s name to Bethesda Games, as there are more bugs then Fallout 76.

I made a typo.

Wait what?

I thought we get each month 500 on log in and 500 more for doing challenges in that month.

Quite funny that the senior UI dev who helped create the new UI and the trading post resigned before the expansion launched.

I begin to see why.

did all no mount bra, not even sure i got them coins

how about you fix the looting system and really annoy the ninja looters taking everything ?

Tbf Blizz had fixed it, with personal loot. However people wanted the old system back, so Blizzard did what they asked. Only optimistic players thought Ninja looting would not happen again, realists like myself knew the change would bring them back.

So much time passed since the weekly reset and can’t believe this is still bugged … :person_facepalming:t2:


I know, my friend has had it up to her eyes with this. You would have thought it would have been caught on the PTR. Like I said more bugs than the launch of Fallout 76.


I’ve completed the whole Traders Post progress, got the message that I’ve completed it, went to click on the chest and no mount. I’ve gotten my coins yes but still no mount. Logged out for 30mins to 1 hour, didn’t work. Today I log back in and still no mount and the bar has been resetted to 0