Constant LUA errors won't let me play the game

So. This problem has been my nuisance for a loooong time now (many months). Sometimes I’m able to fix it for a brief moment, but after a day or two it comes back. Basically I get these weird Lua errors, which makes it impossible to play the game. Most of the time the Bnet app won’t even start, OR if I’m lucky/fast enough, I get to press “play” before Bnet crashes, and WoW launches, only to be greeted with 3x lua errors and a disconnection.

Message: Error loading WTF/SavedVariables/Blizzard_Console.lua: WTF/SavedVariables/Blizzard_Console.lua:1: unexpected symbol
Time: Sun Apr 7 12:36:17 2024
Count: 1
Stack: Error loading WTF/SavedVariables/Blizzard_Console.lua: WTF/SavedVariables/Blizzard_Console.lua:1: unexpected symbol
**Locals: **

Lua Warning:
Message: Interface\GlueXML\GlueXML.toc:1 Error loading WTF/SavedVariables/Blizzard_Console.lua: WTF/SavedVariables/Blizzard_Console.lua:1: unexpected symbol
Time: Sun Apr 7 12:36:17 2024
Count: 1

Lua Warning:
Message: Interface\GlueXML\GlueXML.toc:1 Interface\GlueXML\GlueXML.toc:1 Error loading WTF/SavedVariables/Blizzard_Console.lua: WTF/SavedVariables/Blizzard_Console.lua:1: unexpected symbol
Time: Sun Apr 7 12:36:17 2024
Count: 1

^These are the errors that I constantly get. I have:

  • uninstalled and reinstalled Bnet and WoW completely
  • uninstalled all addon programs (Curse and WoWup) and deleted all addons
  • completely reset the UI using Blizzard’s guidelines
  • renamed the folders/files shown in the error
  • deleted said folders/files shown in the error

I searched through the internet and found some posts with similar problems, but none of the solutions worked for me.

With the game not running, delete any saved variables that begin with Blizzard_ especially

World of Warcraft\_VERSION_\WTF\SavedVariables\Blizzard_Console.lua

Also, delete any addons that begin with Blizzard_

They were virtualized years ago and having the physical ones can cause issues.

Finally, make sure that however you’re launching the game you’re not launching it with the -console flag.

OPTIONAL: You may want to reset all your CVars using the /console cvar_default command in game. THIS IS NOT REVERSIBLE and it’s not something Blizz tells you how to do when resetting the UI for some reason.

After you’ve done all that you may want to run the repair tool.

Oh, and there’s a chance you have multiple copies of the game installed. To verify the one you’re actually running use the Show In Explorer option (or whatever it is on Macs) from the gear beside the launch button.


Thank you for your suggestions!

I deleted all saved variables that started with “Blizzard_”, I had no addons that started with that.

Unfortunately that’s all I was able to do. As I then opened Bnet, I got a .dll error and the app closed itself. I tried again, and tried to launch the game. It took around 2 minutes of nothing, before Bnet shut down and I got greeted with this warning:

Program: A:\World of Warcraft_retail\Wow.exe
Error: ERROR #134 (0x85100086) Fatal condition!
Description: Failed to read FileData ID 1604265 [Key ]: unknown failure
ProcessID: 6824
ThreadID: 1728
Press OK to terminate the application

Hmm this might get some better eyes on it if you modify the OP and move it to the Tech Support category.

That said, I would start by uninstalling the bnet client, restart ur comp, then re-install it. (This will not uninstall WoW)

Then I’d follow these instructions:

Assuming you’re on Windows, you might also want to open the Command Prompt in Administrator mode (right click > run as admin) and run the command sfc /scannow to review and repair any corruptions in the Windows file system.

Edited the category to Tech Support.

I also tried to open WoW from the original launcher, not by using Bnet, but got this error:

"Program: A:\World of Warcraft_retail_\Wow.exe
Exception: 0xC0000006 (IN_PAGE_ERROR) at 0000
ProcessID: 14112
ThreadID: 12128
Press OK to terminate the application"

I’m starting to think my SSD drive is starting to break. Never ever had issues like these before. Yesterday I was able to play for a solid 1 hour after I disabled all of my addons. After 1 hour of gameplay, I closed the game, and Bnet crashed at the same time. When I tried to reopen Bnet, I got the DLL error message:

“A required DLL could not be found. Please download and reinstall”

But today Bnet opened just fine without me having to reinstall it. It was only when I pressed “play” the whole thing stopped working again.

Might be worth checking if there’s updated firmware for your SSD.

How goes the saga?

Sounds like broken OS issues tbh.

I was able to launch the game for a brief moment and play a bit on Wednesday. On Thursday, nothing worked again. I couldn’t even open Battlenet, it just…closed itself. I tried rebooting the computer multiple times, but every time Bnet opened, it closed itself immediately. I couldn’t even uninstall WoW because of this, since it requires the Bnet for uninstallation… I bought a new m.2 ssd drive and just took the old ssd drive out, since I couldn’t uninstall anything.

Now I’m currently installing everything on the new drive, and will be able to test soon. If the crashes and errors continue even on a brand new ssd drive, then I have no clue what to do tbh.

EDIT// April 15th
Aight, an update. As mentioned before, I ended up buying a new m.2 ssd drive and re-installed everything there. So far the game and Bnet have been working without any issues, even with my addons enabled. There’s still some weird stuff going on in-game with the chat windows, but that’s nothing I can do about it. Last time I removed the “services” channel completely as I have no use for it, and it was annoying as the messages are constant. My Lua warnings and game errors started when I did that. So now I’m just gonna move the “services” channel where it doesn’t bother me, and not try to disable it…

So in conclusion; I think my old ssd drive was just starting to die, as it kept going offline/online on its own and kept saying that some games/apps didn’t “exist” even tho you could clearly see them on the drive.

I hope the game will continue to work now in its new home.

Timing was likely coincidental. Sounds like the Plunderstorm patch and your SSD were the cause of the issues.

Glad you got it resolved!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.