CTRL only works for pet bar, not as a modifier for macros


I’m trying to macro my Demonic Circle and can’t seem to get my CTRL key to work.

I want to summon the circle with T, then use CTRL+T to teleport.

Even though CTRL works for everything that’s on the pet bar, I can’t seem to make that work in macros. Nothing is currently bound to CTRL+T.

Any advice?

What’s the macro and what key is it bound to, T?

I tried multiple ways and I don’t think it is the macro that is at fault. Simply because lots of other macros that I have do work. I can only speak of Era though, might be different macro behaviour over there?

#showtooltip Demonic Circle: Summon
/cast [nomod] Demonic Circle: Summon
/cast [mod:ctrl] Demonic Circle: Teleport


#showtooltip Demonic Circle: Teleport
/cast [nomod] Demonic Circle: Summon;[mod:ctrl] Demonic Circle: Teleport;

I use shift+T for the summon and want to use ctrl as mod to teleport. I also tried binding it to T but my ctrl keys don’t seem to have a function in macros. Only shift works. For me personally it looks like ctrl is blocked by the pet bar.

Maybe I should try the macro without a pet out.

You’d need to use CTRL+SHIFT+T if the macro is on SHIFT+T. If the macro is on T then CTRL+T should work.

/cast [mod:ctrl] Demonic Circle: Teleport; Demonic Circle: Summon

Select the ? for the macro icon and see if the icon changes when it should. If it does but pressing the key combo doesn’t fire the spell then you have a keybind conflict and the conflict will need to be unbound. The pet bar isn’t special aside from being bound to CTRL 1-6 by default.

I just wapped it to T now and that works. I’m using this one you posted:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.