Dragonriding Speed Effects

in 10.2 Dragonriding speed effects are considerably more pronounced and now cover virtually the whole screen. Motion sickness is back and its bigger and badder!!!
The unchecking ‘dragonflying speed effects’ has no effect bug was never fixed in 10.1.7 and is still present in 10.2

The only way to disable speed effects is to enable Photosensitivity mode, which is at best a workaround as you are removing effects that do not cause motion sickness and potentially improve the visual quality of the game.

Please consider fixing this bug as motion sickness is no joke!!!

1 Like