Error #132 Access_Violation

Alright, I’ve disabled the few items I had in Startup and will check to see if the error pops up.

Current lineup is:

Adobe GC Invoker Utility
Creative Cloud Desktop
iTunes Helper
iTunes Mobile Device Helper
Windows Security notification icon

Unfortunately, at the moment in seems to take 1,5+ hours for it to appear, so testing it could take a while.

I just had another crash after said 1,5 hour session, while enabling addons fit for 8.2.5, so here’s the error log for that in case it might provide additional insight:

Thanks for the crashlog - it proved rather illuminating regarding the circumstances the crash occurred in!

I’ll name the proverbial elephant in the room right away: this is very likely a memory-induced problem that addons were involved in but did not trigger on their own. The ultimate root cause for the crash was a memory conflict where address space that should be reserved for WoW was not usable - this is of course a common problem for addons (and there were roughly a 100 of them loaded during the last crash), but I am rather sure that is not the whole story here.

Seeing the problem also occurred without any addons installed (as per the earlier crash report) I think the addons are just aggravating circumstances here, not ultimately cause them. There seems to be an actual memory error, possibly a corrupted sector or similar, which becomes an issue soon as memory needs get high enough to eventually tap said problematic sector. This would also roughly fit with the described timeline of events: game/addon memory consumption steadily increases over time, so it’d make sense for the conflict to take a while to manifest.

In terms of troubleshooting that does leave only a few options - it is still possible for the memory areas to be just accidentally blocked by another application, but unfortunately a potential hardware defect cannot be ruled out anymore. Running a RAM diagnostic with a tool like memtest86 would definitely be worth a try, beyond that I’d actually recommend to get in touch with a local technician for a more thorough hardware review.

P.S.: Since it was mentioned in the thread - error #132 has nothing inherently to do with “corrupted maps” . That rumor has been floating about for a while already, but #132 solely indicates a memory-related conflict . Corrupted data files could in theory (but very rarely) cause such issues, so scan/repair may sometimes help, but it is not specifically related or even likely.

I will certainly attempt the memtest86 idea later today when time allows it. Another software issue I’m dealing with does share some similarities with this one, eventually crashing despite doing very little, maybe due to memory issues down the line.

Beyond that, I’m currently still in a session, waiting for any potential crashing before I have to head out for family business. Further testing, along with the memtest86, will happen tonight. I will update with any notable results as I get them.

Thanks for the more in-depth look at the potential memory problem as well. Again, updates will come later.

I’m getting the same #132 “cannot read” error. Reinstalling from scratch didn’t solve it.

My PC has a AMD Ryzen 3600. Which CPU are you using?

Shelve: it is rather unlikely for the CPU type to have an influence on this.

Given the vast variety of potential factors that can lead to memory issues it’d likely be better for you to create your own thread and post your logs there, so things don’t get mixed up here. :slight_smile:

@Vaedsarias Was following up on this post:

I’ll set about creating a post for my crashes.

Well, assuming the 4th pass of the MemTest86 doesn’t suddenly pull something crazy, it currently shows no errors after 3 passes and 4 hrs 42 mins. Luckily, I have no plans in the morning and will thusly continue with the final pass to make sure nothing pops up.

So my RAM doesn’t seem to be the immediate problem and I return to the background applications from Startup. Tomorrow, I’ll likely attempt to enable all my AddOns and just do whatever to pass the time and await a crash from Error #132. If it does pop up, I’ve received some additional advice from a support ticket that I’ll attempt. If I deem any of it worth sharing, I’ll add it later tomorrow after having tested for crashing, in case anyone else might come across Error #132 and find their way here during troubleshooting by Internet search.

Until whatever result I get tomorrow, a fine day to you all.

EDIT, due to not being allowed to post before someone else does:

Good morning to you all!

So off the bat, I decided to try and enable all my addons with their old folders for easy setup, see how long it might take to crash. Only other thing I did was disable Discord overlay, which hasn’t been an issue before, and Touch Keyboard and Handwriting, the number of times active I can likely count on one hand.

9 minutes later, Error #132.

So what might that mean?

  1. Not my RAM, since the MemTest86 found no errors.
  2. Disabling background applications from Startup didn’t save me.
  3. Old folders may be messed up, somehow.
  4. Select few AddOns not updated for 8.2.5 (PetLeash, Gallywix’s Azerite Ledger, and Sunn - Viewport Art) increase the issue tremendously (from a few minutes instead of 1,5+ hours).

So now, I’m back online with another UI Reset, planning to try and setup all AddOns, including the forementioned 3, from scratch to see what might happen. I also activated Secondary Logon, as suggested from a Support Ticket, which supposedly is required and I’ve never known about it. Additionally, one update to Windows for Version 1909 has been acquired.

At this moment, I’ve at least made it past 10 mins of online time, so either luck or some of the bad elements have been handled. Now to wait around some more.

Additionally, here’s the latest Error Log:

EDIT the Second:

I’ve made it back to square one with little in terms of what I might do next.

Gonna try to run nothing but WoW and just let it sit around with a reset UI but if that doesn’t do anything then I’m at another loss for ideas.

New Error Logs after about 1,5 hours and just a few minutes:

And just because, MS Info and DxDiag as of today:

Right, this is getting really interesting.

There are a few things I’d like to touch upon, before we dig further into troubleshooting - specifically, how the determination of an addon to be suitably updated for a particular patch-version of the game is actually made.

On the very baseline this is actually a single line of code within said addon that states which patch version it was made for. There is no testing process to see if the addon has in fact been modified (beyond editing said line), or if its actual code has been adapted/improved in any way to jive with whatever changes the game patch had - so the TL;DR here is that an addon showing as updated can only be trusted as far as the programmer of said addon can be trusted to have actually done it. :slight_smile:

Looping back to the issue at hand: from a review of all crash reports provided the only constant between them was the memory area addressed at the time of crash. There were other factors that overlapped to an extent, e.g. addons being present in most (but not all) crashes, but the memory area was the only one I could verify to be the same every time. I can only suspect the same to be happening in the other application that was mentioned to show trouble as well, since it’d be fairly unusual for two independend programs to encounter similar issues for unrelated reasons.

Logically that’d imply said memory area to be somehow problematic, but since memtest86 did not find any errors on the RAM itself that suggests that this may be rather a result of how said RAM is being utilized by the operating system, or of a factor that memtest86 cannot account for (such as overheating/voltage problems - the test isn’t generating a lot of system load).
With suspected issues of that nature we’re strictly speaking rather far beyond the boundaries of what we’d usually we able to reasonably assist with, so my final suggestion here would be to run some high-load benchmark test on the computer (e.g. Furmark or Heaven/Unigine) and monitor the hardware with a tool like the (very aptly named) HWmonitor to see if anything stands out.

Beyond that - this may indeed be the time to have the hardware professionally checked by a local technician doing hands-on tests, there are a couple of potential issues where remote diagnosis sadly won’t ever deliver fully accurate results.

It certainly has been a crazy ride in the search for answers.

As a current summary of ideas, I stand with:

  1. Continue my current test of a clean slate with nothing else running (currently at 1hr 50m, possibly the longest so far, with the most apparent culprit having been Google Chrome)
  2. Attempt the suggested high-load tests to some extent, not quite a strong suit of mine.
  3. Kindly ask my manufacturer to look it over again, with a focus on RAM (recently had a primary drive replacement due to blue screens).
  4. Simply try to get a hold of new RAM and see if that might help, the true culprit actually lying deeply within the hardware where MemTest86 couldn’t find it.

Either way, quite the devil this is, but I think this is as far as it can go at this point. Either Chrome suddenly reveals itself to be the villain, or my RAM is most likely in need of replacement. So in terms of this particular thread, I thank you all deeply for the great assistance you’ve provided. I’ll leave my support ticket open a little longer, just in case, but admittedly wouldn’t expect anything but the aforementioned advice.

If I locate my villain, I might return here to make note of it, but it seems likely to either be a curious case of Chrome or my RAM, one seeming more likely than the other to me.

So thank you for the assistance and a happy new year!


Having replaced my RAM earlier today, it certainly seems to have improved my experience with another faulty bit of software, while WoW’s still on the fence, but everything I did before managed to ease the issue tremendously.

So I’ll make a premature celebration and say that faulty RAM was my issue.

I once again thank for the assistance and to anyone who might stumble onto this thread in search of answers for Error #132:

Do as Blizzard instructs in their own guide to Error #132, truly.
If none of those work, replace your RAM.
And finally, if new RAM doesn’t help… then unfortunately it’s further replacements for you.

Here’s to 2020, with lots of fun and minimal errors, hopefully!


Hi, was it caused by the ram? I now have the same problem, but doesnt look like i get this error in games from different developer, or maybe the games can go around it and not crash. Also my hearthstone crashes. Warcraft 3 not.

I´ve heard that the hearthstone crashes while playing battlegrounds might been cause by ryzen 3600.


I have MSI MPG X570 GAMING EDGE WIFI motherboard and AMD 3600x system. WOW constantly gives error 132. I bought new RAM. RAM not overclock, just base MHZ, I reinstalled the operating system. WOW reinstalled 76GB downloaded. I have not installed any addons. I have been playing the witcher III, Darksider III, Geim Dawn, Black Desert Online, Diablo III and Wow Classic games for 4-5 hours each, but WOW is constantly making mistakes. WOW my goal in collecting this computer is, as you can see from my playing time, WOW is the main game. The system passes all tests without any problems. Please find a solution. Motherboard current bios version, all drivers are up to date.

1 Like

I have a Ryzen 3700x and RX Vega 64 with g.skill aegis 3000MHz RAM OC to 3200MHz. WoW has been constantly crashing in dungeons due to this error #132 randomly after swapping from NA to EU versions of retail WoW. I am healing with my current character so its really annoying that I crash, everyone dies, and then I get kicked because they think I’m “afk”. I am using 13GB of 16GB RAM and WoW is taking up 4.2GB of that 13GB so there shouldn’t be a problem, but going to buy 32GB of 3200MHz RAM today and see if that fixes the problem.

Your memory OC may not be stable as WoW is very picky with this. Buying 32GB isn’t the solution aside of forcing a different memory configuration. Also latest AGESA did have (still has?) some stability problems in WoW.

  1. Memory OC was stable, there was no overvoltage needed and WoW was fine with it for awhile before it randomly decided to crap out.

  2. I have current AGESA. There was a problem when I got my motherboard (ASUS Prime X470-Pro) with the current AGESA being bugged, so I reverted back until they had fixed it.

  3. Just updated to the 07/17/2020 BIOS Update that stabilized DRAM and Updates AM4 AGESA to 1006 and still having problems- only in dungeons. And this is after I upgraded to 32GB RAM, installed a new SATA SSD, AND upgraded Power Supply from 650W to 750W.

You never know :wink:

You can running much slower XMP and check if it crashes - if yes, then it will be certain it’s not RAM.

Hi Guys

After researching for nearly 15 hours and following all the Blizzard & private guides on how to fix this issue i finally solved the issue.

The memory error 132 /Black/White screen is connected to your GPU drivers and Direct x 11 /12. In my case I have a RX 580 radeon, this problem can be solved by downgrading your GPU drivers and changing the WoW settings to Direct x 11 . For some reason WoW is currently installing the game with DX 12 has default. For those who are having this problem at “startup” without being able to open the game like me just do the following ;;;

open your …World of Warcraft_retail_\WTF… , open your ( file with note and change the "SET gxApi “D3D12” to D3D11 and try to re run the game.

This will change the directx settings from 12 to 11.

Enjoy Merry Xmass ! :partying_face: :partying_face: :partying_face:


this solved my issue, thanks! i guess the reason to that is that you need win10 for dx12 and i am running on win7

We were experiencing this issue for the past few days. It came to the point where we had to drop DirectX12 and use D11 instead which seemed to solve the problem (but for how long, I won’t know).

Have you found a solution to this? I have close to the same setup as you and the same problems