Flashing "trees"

Hello people of the forums, since a few days I have this weird problem on my characters that makes all leaves,trees bushes things like that flash/flicker the whole time I do not know what it is but if someone has any adivce on how to put a end to this that would be highy appriciated.

I have tried reloading the game that did not work.
And i have tried restarting the game what also did not solve anything.
EDIT: https://imgur.com/a/z7ZiBxU


I’ve got the same problem. Some player characters, objects, NPCs and environment details keep flashing/glitching. Didn’t notice this until today.

I used to have the same issue a few weeks back, when upgrading my monitor.
I fiddled around with the in-game settings and found that setting anti-aliasing to MSAA 4x helped a lot (your mileage may vary).
Also, I reinstalled Nvidia drivers and had the Nvidia Gforce Experience optimize WoW. No texture flickering since then.
Hope this helps!


Not sure what kind of troubleshooting has been done so far, what I would highly suggest however is to make sure that the latest stable driver and OS updates* are being used.

If the issue persists after this, try repairing the game.

*There is currently an issue that is being tracked with Nvidia 460.xx drivers. If you have this driver, I would suggest using 457.51 instead.

1 Like

it would be well to somehow monitor the situation, when new versions of drivers will work correctly again and we are able to update them.

Hello people Tharuu here again, I wanted to make a update on this at least in my case.
And I still have the problem I tried scan and repair within the battle.net app but it did not work as well.
I have the latsest driver of my graphics card which is a nvidia geforce 1070 btw.
So I really do not understand why i have this issue.

EDIT: https://imgur.com/a/z7ZiBxU

This is part of the issue right now. You will want to roll back your driver to version 457.51 at least.

1 Like

Hello all Tharuu here again, I think I have fixed it for myself by updating my bios.

oh maybe turn down settings?

Hey, i had the same, even in dungeon.
But it was like really really noticeable, it was flickering like hell.

I fully removed and reinstalled my gpu with a few new drivers.
I updated windows (reinstalling it failed cause my hdd is faulty then i didn’t).
I tried every settings and it looks like playing shadows on minimum was the best option.

Then i tried disabling addons but that wasn’t the problem.
It’s cleaning wow cache that helped me.
It even improved my fps wich were becoming bad for the usage of my gpu.

Hope it helps

1 Like