Focus cast key issue


I have an issue regarding the “focus cast key” setting.

As an example I have the “s” keybind set on my bar to be Polymorph, however, when I press alt-s (the setting is set so that alt is my focus cast key) and have a valid focus target set I just get the error message “You have no target.” Is this a known issue or something I can resolve somehow? Ive already tried clearing cache and the likes. Thanks in advance!

Is your self cast key also set to alt?

And are you using Blizz bars or a bar mod?

Hey thanks for the reply!

My self cast is set to auto (and ive tried to switch it around with no change to the issue)
And im using the default blizzard bars.

edit: had made a ticket aswell and got the generic reply to just reset ui which obviously I have already tried, sadly.

Have you also ruled out that Alt+S might already be bound to something else?


Yeah, not only have I done that but I have tried with right about every single keybind I have, not just S, that was just a quick example. Thanks for trying to help though!

1 Like

Ok, I’ve confirmed that the focus key setting works as intended for me with default bars and alt-clicking the spell.

I tested it with Mind Vision as it’s one of the few buttons on my bars that isn’t a macro and it’s a spell that doesn’t care if the target is helpful, harmful, or in your group.

So next thing I would test on your end is if holding down alt and clicking the button works.
Also, this does not work with macros; so if you’ve been testing with a macro that’s part of the problem.

It doesnt work if i click it either, and it also isnt a macro. What I have checked which I forgot before is a different character, so I went on another mage I had and it did work on there… Which makes this issue even more odd.

Try it straight out of the spell book. Like don’t even put it on your bars.

And also try it with all addons disable just to be sure one of them (which might be enabled on one mage and not the other) isn’t messing with things.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.