Get Your Trading Post Items for February!

Thank you all for beta testing!


This feature is really cool actually, just got the wizard hat + cloak combo
looking forward to the future items

1 Like

i just got the max points and should have recieved the mount ashadar but its nowhere to be found its not even listed in the mount journal have i missed something here?


Well. Someone has to, don’t they?

1 Like

Yea. Scroll up and read my first post of this topic.

Edit: My bad. I confused it with another item.

Quest didn’t give the 500 tokens, tried to buy a staff with the other tokens I got from the DF edition, it said internal error, took the tokens and no staff received.

12 out of 10 goblins swear it works as intended.

1 Like

you have to loot cache again

1 Like

That Nexus-themed bow looks awesome!

i’m sure that’ll be sorted easier than losing tenders while trying to purchase an item
I gotta say that mount looks awesome
i hope it flies !

i really hope its all get sorted i know i was really fast completing this perhaps that was a mistake

I bought the hecking Mace thinking I can equip it as a caster like the Dark Iron one, and didn’t know I can refund it, bc it was right after servers were up

Thank you! And good luck to you as-well.

Edit: scratch that
those numbers are ‘travel points’ and each 200 reward 100 tenders

ok this is confusing lol

yea it went to 1000 and now it says you have collected all rewards for this month but the mount is nowhere to be found not in chest, mailbox logged all chars i completed tasks with and its not even showing in the mount journal as even existing


Per month. You’ll have to wait until March.

1 Like

I tried to buy the Shard of Frozen Secrets dagger mog and i got “There was an error communicating with the server. Please try again later”

EU is apparently Beta Testing for NA, and they said they don’t even wanna give us refunds
through customer support …

Can’t complete the quest Tour the Trading Post. It does not register talking to the npcs and reviewing the trading post post.

On a different character I can’t even open the Collector’s Cache.

I got 600 tokens from my 1st interaction with chest, after that when i completed quest to get familiar with the post i got another 500, than chest was shiny again and when i clicked it i got another 500 so that amounts to 1600, but after i opened the buying tab i only had 1100 tokens wtf is this i didn’t buy anything. Where did tokens go.

In this case, we are, because unlike usually this isn’t tied to the weekly reset. NA still didn’t have their February 1st reset.