Healthbars not showing

Recently I encountered a weird problem with nameplates in game. Out of nowhere the healtbars stopped showing. I’d like to emphasize that names are showing perfectly and can be managed easily in the Interface / Names menu, it’s the healthbars that are cannot seem to work.

I tried these things and none of them worked:

  • Scan and Repair tool in bnet options
  • playing around with ESC / Interface / Names settings
  • deleting nameplate addons (KUI and Tidy Plates)
  • /console cvar_default
  • deleting WTF file

Has anyone ever encountered something similar? Is there something I’m missing out or I have to completly purge wow from my PC and reinstall it again?
Also please don’t tell me “just press V”, thank you.

Have you tried disabling all addons, and not just the nameplate ones?

Yes I did.

I’ve seen that bug happen occasionally since the patch with ElvUI’s nameplates. Thought it was something related to that particular addon but maybe not. That said, when it happened it didn’t affect all nameplates, only certain ones, including different mobs of the same type.

Resetting your CVars to default would have disabled the “always on” aspect of nameplates so I’d make sure you’ve re-enabled that.

/run C_CVar.SetCVar("nameplateShowAll", 1) ReloadUI()

This helped, but only in the particular order wich was:

  1. deleting all the addons (disabling them was not enough for some reason)
  2. using /console cvar_default
  3. using /run C_CVar.SetCVar(“nameplateShowAll”, 1) ReloadUI()

And when I relogged on other alt, it was broken again, so I think commands are just not enough in my case.

I have no idea what is happening, I wanna play the game and not mess with broken UI, so I am deleting all wow files and I’m just gonna reinstall it. Thank you for your efforts to help tho.


i had the same problem , tried everything as the guy above ,but this seemed to help , very nice ! now i can finally start my benediction quest!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.