Horde Mechagnome - Give Up

I was kinda hyped to play one but if Blizzard dont want us to play Alliance then I will not. I cant complete Urgent Care quest because there is no Steelspark in Boralus. I completed all yellow quests in Mechagon as Alliance, have Exalted and killed King Mechagon as Horde.

While being unable to complete this quest I abandoned it and returned to Stormwind. Looks like last part of achievement required to unlock this AR is not completed so we either have to “just” kill mythic boss (King Mechagon) at our noob Alliance heroes or complete the quest for killing him that means farming reputation to revered/exalted. Like I want to do either.

Let Horde rule forever~

Is there a meme party i missed? I’ve only seen outrage of vulpera not being neutral

Any tips here?

That might mean that last part of achievement I mentioned is a “UI BUG” but still quest destination aka NPC is missing.

Did you get both achievement on the same char though ?

Blue mentions the same account :thinking:

Also I can pick-up the quest :sweat_smile:

Why they would give it to me if I dont meet requirements :pleading_face:

Try hopping in and out of wm ? Maybe it’s the phasing ?

I read entire thread Sinaaki linked (comments) and looks like Horde was unable to pick-up the quest. Blizzard “hot fixed” it and now we can pick it but cant deliver at destination (Boralus port).

Will see if they will fix it again but its a wasted time for sure. Like they dont have PTR or something.

The PTR was used to make sure everything went smoothly with the vulperas.

1 Like

I am stuck on the same thing atm. Kelsey simply does not exist in Boralus for me.

I will persevere and report back if I find anything that works.

Watch out for the same NPC later when you are going to help the king of gnomes. At one point you will assist her in getting an item you need to complete the storyline. I was almost alone there today and it bugged seven (!) times out before it worked. If you don’t get the item in question, then remove the quest and start over.

Unfortunately this is way before any of that. I go to the Embassy and I am given

‘Urgent Care’

I am sent to see Kelsey in Boralus, but there is a ? on the map but no NPC. She is not in the same phase as me. I have tried both WM on and off.

So I can’t even get as far as doing any unlock chain sadly.

1 Like

If I remember she’s at the fountain near the salvage machine in Boralus, correct? I think the server just can’t keep up with the requests at the moment.

That is where she is supposed to be but instead I get air, no Kelsey

1 Like

I see. That’s really unfortunate then. I have checked some topics for you on reddit and in the US board but some people have the same issue with no real solution for now.

I hope it isn’t an inGame switch-problem when it comes to the reputation and that several unique mini quests need that maximum reputation on the character you play - but I have done it on Leafkettle who had done all Mechagon-related quests, maybe they haven’t thought this far ahead and proper testing with alts.

If I’ll find something, I’ll tag you and post it for other players as well.

1 Like

Thank you x

1 Like

Following. Having the same issue.

Requirements done on a Horde-toon.
Ive unlocked mechagon on my alliance, so that shouldnt be a problem.
Still no luck

1 Like

Still no luck?

Not so far, I’ve tried going to Mechagon, in case I can see a version of Kelsey there but had no luck.

I tried relogging in case that would have any effect.

I tried dropping and picking the quest up again. No luck.

I tried running the last wing of the Mechagon dungeon on Heroic, nothing.

Same as here then.
I wonder if it has anything to do with the achievement that is suposed to be account-wide.

When I check the banner in SW, one of them shows up as “grey” on the char that didnt obtain it in the first place