Huge FPS drop since update


#1

Hi all, I’m pretty sure it was since the last update, but for a while my fps has dropped to under 10, I’ve never had this issue before and have always had it very high alongside Ultra graphics setting, however even if I lower the graphics option to low I still cannot raise the fps by much more than 10-15 :frowning:
I’ve tried reinstalling and playing with the system setting in game but nothing is working!
Anyone come across this and has any advice it would be most appreciated :slight_smile:


#2

Since when? What update?
I’ve been getting fps problems, mainly in combat, since this wednesday (16 january). Was there an update that time or you mean when 8.1 hit (over one month ago)?


#3

Hey mate I know its really not helpful but I can’t work out exactly when, I didn’t play during December except maybe the first week that and I noticed the FPS drop about 2-3 weeks ago, this was the first time logging in since early December when everything was fine, I only thought it might be from an update as before I could play, battlenet was downloading something, so it’s hard to know if its been caused from the Patch over a month ago or one of the updates they do.


#4

I came here looking to see if I was the only one seeing this, glad to see I’m not.

Like it has been pointed out it seems the problem surfaced a couple of weeks back, I’ve gone from having a fairly solid 80+ in pretty much any zone to a agv of 40. The games still playable for me.

I can get back to 80ish or higher fps if I seriously lower my settings but they are all the same as they were before so I don’t think that’s a road I’m interested in going down just yet?

I’m running on what I think is still a pretty decent system (surely more than enough for wow)

i7 8700k
32gb ram
GTX 1080ti
2560x1440 144hz monitor

I’m wondering if there has been a behind the scenes change to wow that’s having some unintentional side effects


#5

Hey mate sorry to hear you’ve got the same issue, yeah seems like we’ve got the same thing, my PC isn’t as good as yours but has always been able to play it on the highest settings with no issues, if I set it to ultra I now get 10 and under fps, the best I can reach is on low and I can just about manage 25-30, and yeah happened same sort of time as you’re saying, I’ve tried loads of different things but can’t fix it :(,