Important FPS drop since patch today [PC]

I somehow got the problem fixed by doing the following. GTX 970, i5 6600k, 4K resolution

  1. (I personally did this but do think that is optional so I suggest you try to skip this step) Make a clean setup of nvidia driver to previous version. I chose 446.14.
  2. Set your game resolution to the lowest possible (1280x720).
  3. In advanced settings set your Rendering API to legacy directx11 and then back to what you used before (directx 12 for me).
  4. Set game resolution back (4k for me).
    So in general you want to flip rendering API in order to reload it while using low resolution. It worked for me and I have no idea why lmao
10 Likes

Any update from Blizzard would be nice. There is a player which analyzed the problem and identified the nature of the problem too, yet the issue is still in game.

4 Likes

Blizzard when will fix, how can this be?
https://youtu.be/lPTmzhMoeLk

1 Like

OMG how is it possible that you have the solution and Blizzard does not…
This indeed fixed the problem.
One note though, i did not had to change graphics drivers i only did step 2 till 4…
Got a fluent 60 fps now again where i had fps drops to 40 before…

Blizzard sorry but big shame on you that this post and this solution does not have any more attention…

Edit/Update: I have to do this every time though when i load WoW… Going from a stuttery 40 fps in Bastion to a normal steady 60 fps each time after these steps…

Yacht ain’t gonna buy itself. I wouldn’t be surprised if they just put the issue aside in a corner after looking at it briefly.

I had the same and went into System, Graphics and then disabled the Vertical Sync !
(it stops the water falling out too ).

Bump and update: I have to do this every time though when i load WoW… Going from a stuttery 40 fps in Bastion to a normal steady 60 fps each time after these steps…

For me personally it doesn’t fix it, but it’s good that some people managed to find a solution. Maybe this will help hint at a broader solution for everyone.

Thanks for this workaround, fixed the drop in FPS.
it’s been bugging me for months now in SoA !

Do you think the problem lies between the Graphics API and some sort of rendering issue with the driver?

Bumping. Thread fell down 300 kilometers because Blizzard doesn’t pay attention.

Did anyone try playing on PTR to see if the issue is still there ?

Bumpelisious :smiley: Does anyone know if we can automate this process? Starting WoW everytime and changing this feels retarded… This should be fixed.

And no response what so ever from a blue anymore is just sad… We found the solution but you don’t care to respond? Better try to silence the problem and then maybe in a future update we get a fix which will not be mentioned?

@Tyrskorn Please read further in this topic and you will see the solution to fix this horrible problem…
Can you give a sign of life so we know you have seen this? And could you send this information to the tech. dep. who can fix this maybe before or @ patch 9.1

Thank you.

PTR still having FPS issues that is in the current retail.

Just FYI if you have an nvidia graphics card and you use the Nvidia control panel and set the wow profile to maximum performance there is a chance the game ignores the profile.

I noticed it happens occasionally and randomly.Sometimes I run the game and it follow the nvidia profile and sometimes it doesn’t.

You can easily tell if its not following the profile if you have high performance chosen for WOW.exe and the clock drops lower then boost clock.

Reported the issue months ago but it seems to still be there.

Man you are a legend! Working for me up to this moment

Please do not bump older threads.