Keybinds changed for actionbars

For me å ö ä § and ’ are not working or work incorrectly. Like if i press ’ it is detected as if i had pressed ä and vice versa. § is detected as \ . Changing keybinds still doesnt fix the issue for me. This occurs across multiple computers and keyboards regardless of their keyboard layout. Edited to add that this behavior is new since 9.2

3 Likes

Here Same issue i tried multiple resets from my mouse / keyboard - checked windows keyboard settings i did no changes since yesterday no updates …
This is definetly a wow problem
For me the ingame chat works fine if i try the buttons in the chat window but if i try to check Keybinds for me its the buttons ß and ´ if i try to keybind them it shows me [ and ] i think blizzard and theyre implementation of “!click casting” added this problem

Please Provide more Posts and upvote we need to fix this

2 Likes

yeah keep posting here if u have same problem and make bug report.

2 Likes

100% since 9.2
Chat my keys work fine but for some reason for action bars they are changed to \ = and [
like how does § + ´ become those keys

2 Likes

Same, it doesnt work!

2 Likes

I posted on this in the technical support section. Its the same for me and most of my guildmates. Stuck with wrong keylayout.

1 Like

This was posted on Technical support but somone moved it here

Same for me, new problem since 9.2.

Same problem with norwegian letters (æøå) and also ’ and |§ etc… Its even the same bug on both my EU and my US account. Both if wich worked fine yesterday.

1 Like

Why did they move it to ui when its clearly a wow related technical issue

4 Likes

This got bugged for me last couple of days on ptr aswell, but didnt bother, since it was most likely a ptr bug. But here we are.

3 Likes

how could they release such a big problem!??!

2 Likes

Can we assume they see it here, or should we report it in game as well?

there are alot of posts about this issue and it will be a bigger problem in a couple hours when ppl finish work

i can not report it ingame. if i want to report a bug it gives me a link to the us bug forum. try your luck ingame but i doubt it will work.

I also have the same problem, with § and åäö. but it still works if i rebind the keys, the character will be different but the key will work as before. § will be \ instead.

not sure if rebinding a lot of my keys is the move tho. in case they fix it

I am having this problem, please fix ASAP.

I’m having the same issue. When I use my corsair scimitar anywhere outside of the game the bind remains as ´ but within the game the bind swaps out to } or something alike to that. Same issue with + turning to = too. Finnish keyboard.

I think a lot of people have this issue (including myself), but since it only affect keybindings and not for example chat. A lot of people isn’t aware of it yet. Asked a couple irl mates and they both had it without being aware of it because they don’t rly use those keybindings that much.
Sidenote - We are using Nordic keyboards, if that could be part of the issue