Wrong Hotkeys

My keys ^ ß ´ ö ä ü and so on arent working as of today. But only when playing. In Chat they are working. Anyone know what that is? My keyboard is set to german and english mapping is deleted so it doesent change from “standard” setting for me. but it seems to me that wow is now using english keyboard settings?


I’m experiencing the same thing. The chat is using the keyboard settings from windows, (for me that is a Norwegian keyboard layout) while the keybinds for abilities seem to be using an English keyboard layout.

I have the same issue as the above, but for me it is the button " | " which is left of the button 1 on my Norwegian layout keyboard. This was not an issue before today after 9.2.

Edit: I have other Norwegian friends who is experiencing the same issue with different kind of buttons.

Keybinds changed for actionbars - #2 by Qro-argent-dawn here is another forumpost same problem

Same here for Finnish Keyboard Layout. I dont have English Layout installed but from what i can see the keys it changes to dont correspond to English layout § + ´ become / = [.
This is a 9.2 issue i would guess due to !quickcast

I’ve tried removing bindings cache, removing addons etc. nothing worked.

As a workaround I just rebound my ^ key with whatever / is supposed to be. It actually works with mutiple keybinds. I also rebound my # key with whatever / is and both keys still work.

we should not have to rebind our keys, it is literally an input that works for chat but not for casting it doesnt make sense

1 Like

Here Same issue i tried multiple resets from my mouse / keyboard - checked windows keyboard settings i did no changes since yesterday no updates …
This is definetly a wow problem
For me the ingame chat works fine if i try the buttons in the chat window but if i try to check Keybinds for me its the buttons ß and ´ if i try to keybind them it shows me [ and ] i think blizzard and theyre implementation of “!click casting” added this problem

Please Provide more Posts and upvote we need to fix this

1 Like

exactly they changed keybinds input to wrong keys

Keybinds changed for actionbars - #13 by Kíkkan-auchindoun apparently was an issue on PTR

1 Like

î have the same problem here.
on my swiss keyboard i have on button 11 and 12 ’ and ^ but ingame it is recognised as [ and ]. Ingame Chat is correct but hotkeys are not.
I didnt tries other keys maybe there are more keys wrong. Same bug i had on the ptr and now it went life

edit: ok öäü also dont work. keys right side of L and P :slight_smile: and § which is left of 1. so its totally f. up

1 Like

yes same here

same here, also there are muiltiple threads all with the same problem of special characters following a different keyboard layout. Possible that introducing the new binding features locked a specific layout in for them. Here are some other threads on this

1 Like

We didnt even have a bug report forum or a ingame feature. they linked me to us forum lol but i can not write there.
hope the devs see those threads and release a fix asap. i dont want to change every key and then after fix change it back -.-


Same here.


It seems that the keyboard layout for hotkeys was changed to English with patch 9.2, so if you have another language selected for your keyboard some hotkeys will not be recognized. Your language layout should work normally in chat, only hotkeys are affected. We are investigating this at the moment and it should be fixed soon.

Background software for keyboards, addons and settings in WoW do not appear to be responsible for this. The only temporary workaround is to open the keybindings in WoW and set the same key you used before again as Key 2. This will allow you to use the same hotkeys as before and can be reverted once the issue is resolved.


I was about to rage that the ingame support tool redirects you to the US forum version but now, with your answer, I’m just disappointed that your QA department doesn’t even test the simplest things like keys…


Same here with French keyboard layout bépo, a few binds working since Vanilla are unavailable. No problem in chat.

DE layout here, same error. This issue came with the latest PTR patch, by the way. I reported it to the devs via Twitter, with no success apparently.

1 Like

Hello again,

We did some testing and the following workaround seems to resolve the issue for some players:

In Windows go to Settings > Time & Language > Language > Administrative language settings > Change system locale > Disable “Use Unicode UTF-8 for worldwide language support”

If the box is not ticked, please tick it, press OK to save and then open it again and untick the box.

The only temporary workaround that definitely helps for now is to open the keybindings in WoW and set the same key you used before again as Key 2. This will allow you to use the same hotkeys as before and can be reverted once the issue is resolved.