Live chat unavailable for a week

I’ve been asked to create a live chat to speak with customer support regarding issues i have with retrieving an old account.

For the last week I’ve been unable to submit a ticket across multiple devices and browsers.

Customer services on twitter have constantly linked me to the page to create a ticket but it still shows as unavailable.

What am I supposed to do here?

live chat hasnt really been a thing for years now and is only available a couple of hours a week for only certain, very specific problems at certain times as far as i know.

since you tried it on different browsers, have you tried to clear your cookies and whatnot? maybe a dns flush would help as well.

1 Like

Hi there Melawin!

Sorry for any inconveniences caused! Our Live Chat is open 7 days a week for English support, and on weekdays for all our other support languages. Make sure to open your ticket between 13:00 and 23:00, as Live Chat is closed at all other times.

Please note that depending on your issue, you might not be able to open a Live Chat (Account penalties, for example, cannot be discussed via Live Chat). If you have trouble selecting an appropriate category for your ticket, use the generic “Not listed here” category (Direct link)

That page linked by Dodcoszmau works for me so if it doesn’t for you and you’ve tried multiple devices then it may be something on your internet connection, maybe even your ISP.

1 Like

Still not working. Im with Virgin Media, so i believe that this could be a problem.

1 Like

In that case it’s not the ISP as I’m VM as well and the page loads without a problem. Did you do what Schmusedecke suggested and clear cookies? Also clearing your browser cache might help.

1 Like

Cleared everything across 4 browsers. Enabled java and pop ups.

4 devices now and still nothing.

1 Like

What are you actually seeing on the page that the link leads to?

I see the options of both web and live support. Live support is highlighted although has a line through the speech bubble with a message underneath it, stating that it is unavailable.

Onto my 5th device this evening and still no luck.

1 Like

That means that its just… Not available. Either because of the nature of your issue. Live chat is not available for all issues. Or because you are trying out of hours.

That is absolutely nothing to do with your connection.

That is very weird. Yesterday it offered me both ticket and live chat. Live chat had a line through it with the hours it was open below (basically around lunchtime if I remember right). This morning, it’s not offered at all, just the ticket.

1 Like

It’s only open 1pm to 11pm gmt, so that would be accurate.

It’s worked for a friend of mine using the link above but not for me. Just really frustrating that I have tried so much on my end with no success.

Checked from my side too, this morning livechat is entirely not available but 2 days ago it was when I was around to check.

Just a simple question, what country are you in?

I’m not OP, I just wanted to guess that since OP said they have Virgin Media that he/she is in the UK.

Yeah im in the uk

It’s back up, saying ‘Open 1pm to 11pm GMT’. However, 20 minutes into that time, it’s still saying Unavailable.
Maybe @Dodcoszmau or another blue could help, now we know it’s not a technical problem, just a problem of it not being available at the time when it says it’s available. If you see what I mean :slight_smile:

1 Like

I think if there are too many people trying to use it then it says unavailable. I am not stating that as fact just a guess.

Usually all you need to get access to an old account is CD keys, security questions, those kind of things. Depends if you mean old Battle.net accounts or really old account that’s not merged with a battle.net account.

I take it you are aware of what Blizzard can and can’t do with old accounts and the consequences of moving warcraft accounts to a new battle.net account.

The one thing they won’t do is give you access if it’s under a fake name or not your name. They cannot merge battle.net accounts either.

its 13:52BST now and live chat is not open. Tickets are being resolved, without being resolved, and im unable to play my character.

I guess it was on one of the TBC consolidation realms.

You shouldn’t really necro an old thread that’s unrelated.