M1 Mac BattleNet and Agent Broken - Stopping WoW installation

You still have to download some wow to download wow.

This MS Blizzard could never build wow.

This work!

Yea its work Really thank you !

Really Thanks, 2days left but this work!

Mate!!! this was the trick!

The solution for the fastest indices downloading is to locate the logs inside the ‘/Users/Shared/Battle.net/Agent/Agent./Logs’ or ‘/Users/Shared/Battle.net/Agent/beta/Logs’ folder. Open the most recent log file with a name starting with ‘bc_’ such as ‘bc-20231028T115506.log’. In this file, you can find all the failed requests for downloading indices.

Next, you should remove all other data except for the HTTP references like ‘://us.cdn.blizzard.com/tpr/wow/data/e7/6b/e76b6b48e54fc9cbea3fc5fb2217d277.index’ and save them in a separate ‘indices.txt’ file (useful regex: (http://.*')). Then, using the terminal, navigate to the folder where you saved the file using ‘cd /path/to/indices.txt’, and enter the following command: ‘curl --remote-name-all $(cat …/indices.txt)’. Wait for the download to finish (5-10 min).

After the download is complete, copy all *.index files into your ‘~/Applications/World\ of\ Warcraft/Data/indices/’ folder. Finally, click the ‘Update’ or ‘Install’ button inside the Battle.net client.

Hey guys
Unfortunately nothing help me to fix this problem ….
I really don’t know what to do now :frowning:

1 Like

November 2023 and this issue still isn’t fixed. Help is appreciated

I tried every solution listed on the web:

  • filevault encrypted / non enctryped
  • beta version of battle.net
  • killing manually agent.app process
  • full disk and app management permission for the client
  • adding exception to the firewall

Still unable to install it

I tried every solution. Did not work. I can install heartstone and hots but cannot install wow.

I’m still getting this issue - managed to get the game to install but now it has come back with this evening’s update. It’s been months Blizzard please prioritise and fix.

this is what fixed it for me:

Download WoW-folder from a friend (I have a link if needed).

1: Close Battle.net.

2: Open the Activity Monitor (Application folder > Utilities) and end all Agent.app processes.
Alternatively: Restart your Mac.

Also make sure you installed the newest Battle.net version: https://www.blizzard.com/download/

3: Go to the Application folder and delete the “World of Warcraft” folder (if it exists).
Unzip the downloaded “World of Warcraft.zip” file and place it in the Application folder.

4: Launch Battle.net, go to WoW Classic (not WOTLK) and click on “Install”. When Battle.net will ask where to save the World of Warcraft folder, it should be the same Application folder.

The installation should now run.

After the installation I would suggest to reinstall WoW Classic.

Then you install Retail. It’s worked for me. Twice.

1 Like

Battlenet is such a crap. I’ve downloaded 10.2 today, I’ve played it in the morning. Now I’m trying to play and can’t. Battlenet says there is another retail update but it won’t download. I restarted and repaired launcher and after that it suddenly shows retail and classic update lol and after 2 minutes of “preparing” there is an error that update can’t be downloaded. Entire launcher is broken on M1.
Thank GoD I’m used to Blizzard beeing failure lame duck so I don’t have any expectations. I can only say - GREAT JOB.

I normally do not bother using the forums. But this is getting out of hand.

I understand that MAC users are not a high enough % of the community to really invest mode troubleshooting into it, but i’ll leave you with my little tale for your morning coffee and laugh at work.

For the past 2 months, I have to relog every single time I use wow. Ok, I undestand the launcher is crap. I can deal with it and learned to love my little brakes ( go in the launcher, watch it DC, close it, close it, force quit, send report, reopen, credential, yey enjoy my subscription).

As much as this is fun tonight has been on a different level.

I go through my normal process above. Fun, I know. then I get a cheeky update. Imagine how fun it is to get an update and get BLZBNTAGT0000138F over and over.

So I go on your forums.

Step 1.
You didn’t make any changes to your machine, no worries it actually your Firewall. Don’t be stupid and follow our steps.

Done, no results.

Step 2.

Close or reinstall Battlenet. Done no result.

Step 3.

Update OS. Done no result

Step 4.

Repair the game. This one was particularly fun. Not only did I get error after error but it also didn’t work.

Step 5.

Unistal the game. Well this is the epiphany of the evening. I was stupid enough to do it. Now… can you guess what happens? I have 96 GB to instal and I get BLZBNTAGT0000138F at every 1%

Now, the fact that I am still doing this is a testament that I am a lousy consumer and I’ll probably stick with this game despite your many many many faults both social and technical. I don’t credit that to you, I do credit it to having too many connections in game to just leave. But it’s the little things, things like wasting 4 hours of my life, that will push me at some point to just realize I am at an age where maybe playing WoW is not the best use of my time going further.

Really appreciate the overwhelming support you have shown so far to this issue and looking forward to your continued technical support.

1 Like

help me too thank you

Guys, here is what you’re going to do. There is a problem with how folder permissions work and interact with battle.net (I don’t have any CS background to explain how and why this happens beyond what I just said). However, the key is not in Privacy settings and general File & folder permissions. It’s in the individual folders themselves.

Make sure that battle.net is closed down and all other relevant processes killed in the Activity Monitor. Use Force Quit function if necessary. I am going to assume you’re running the beta version of battle.net. Next, open the applications folder in your mac and right click and select Get Info on the battle.net application. Click the yellow lock in the lower right corner, put in your password, and then click the three little dots to the left (that were greyed out before you unlocked it) and press apply to all enclosed items. Now, do the same for the WoW folder - but not just the folder itself, it should be the folder that contains it. For example, I have GAMING folder in my applications and enclosed World of Warcraft within it. Do the same thing for your folder - unlock the yellow thing, apply to all enclosed items, etc. NOW turn on your battle net, make sure it updates, and then try installing/updating/playing WoW. It should, at some point, work. IF you get a CAS error, just restart the launcher, kill the processes, and do the same thing again. It should work.

There was an update to bnet app and after that it worked for me without any workarounds mentioned here. So this might be officially fixed. I did delete the whole agent folder before even reading this thread in order to try fixing it by myself. Didn’t help, until the bnet update happened.

Similar issue here. M1 Mac Mini.
I was able to play 2 days ago after the 10.2 patch. Yesterday I did not play. Today during the Update or Scan and Repair:

Whoops! Looks like something broke. Give it another shot.
Error Code: BLZBNTAGT0000138F

The net connection is stable 500/20 Mbps. I tried to close battle.net app, forced to stop the remaining agent processes and after relaunch the app, but nothing has changed.

1 Like

Battle.net Version
Battle.net Update Agent Version

Your solution is worked for me. I am not using the beta client, but the problem was probably the same.