M1 Mac BattleNet and Agent Broken - Stopping WoW installation

Hi there

Hoping someone can assist me…I’m playing on an M1 Macbook Pro 14, and have had few issues until now. I tried to log in today, to be told that an Upgrade was necessary. I clicked it, it did whatever it needed to do and then WoW wouldn’t “Play”. Instead, a bouncing instance sat in my bar and I was forced to quit.

I thought I would try the Repair tool - all this did was start to creat multiple Agents, completing consuming all CPU power. I force quit, and came back into Bnet, to be greeted by the same Upgrade, only now it would do nothing but create many Agents.

I uninstalled Bnet, and had the same issue.
I unistalled WoW and Bnet, thinking a fresh install might help. This time, Bnet would load, and allow me to click Install. Install lasted about 10s, and then changed to Upgrade - only installing a blank folder for Retail. If you clicked Upgrade, tons of Agents would made, hogging all resources and nothing would happen.

I then followed all the Support articles removing all traces of Blizz/bnet/Agent from the machine (libraries and all). Tried again and same response.

I reinstalled the OS, tried again. Same thing. I borrowed my partner’s M1 MacBook Pro 14 and tried to install Bnet and WoW there - same issue. Upgrade appears, and many instances of Agents spawn.

Please let me know if there is a fix for this issue - it’s infuriating and does seem to have come out of whatever was done over reset.

All testing done on fully updated M1 Macbook Pro 14s; all Support article instructions followed with no result.


Tried installing again on a fresh OS install: After pressing “Install” for wow, it initialises for a few seconds and then changes to “Update”. From there the “Update” button goes on/off and creates a new instance of Agent over and over…never getting anywhere.

Please assist!


Same issue with my MBP 14" M1 Pro.

Agent log shows 404 when trying to connect with Battle net Servers.
I could install Battle Net without any issues and can access Battle net in the browser but the Battle Net App starts multiple Agents (my Mac reaches 100% CPU usage) and nothing happens.

I reinstalled WoW and BattleNet Launcher multiple times and still the same issue.


I’ve been struggling with this exact thing. Completely froze my laptop after running too many of those agents that I had to force quit through the activity monitor.

Reinstalling Battle.net client didn’t work, rebooting didn’t either.

It does seem to ask me for my admin password every time I hit update so I imagine it’s a rights issue gone haywire?

1 Like

Same thing here. I find that even installing Bnet is slow and flaky, and the app itself appears to be very resource heavy. Just wanted to know from the other commenters: what version of macOS are you on?

Same issue today.

Something came up saying privacy wouldn’t allow agent to make changes, but how do I add it so it can?

Go into privacy - then into app management and allow Bnet and agent all access,

just worked for me.


I’ve tried this, but it still does not seem to work. Both Battle.net.app and Agent.app are in there now, yet it still keeps asking for access and failing with the generic error…

Having the exact same issues as everyone mentioned above. Agents going haywire putting lots of stress on the cpu.

I have found a way around it that involves using a windows machine. Simply downloaded the game files and transferred to mac using a usb. I only copied the DATA folder and then hit scan and repair on the battle.net launcher. Game updated and everything works fine.

If you are desperate and dont have a windows machine lying around you can maybe pop into your local tech store and use one of their machines for example. Hope this helps.

1 Like

I’m having the same issue, M1 pro

I wanted to return for dragonflight after having a wow break for a few years. I guess this is a sign.

1 Like

Same issue too, even with after tried to transfer data folder with a hard disk & changed my battle.net/Agent privacy settings to full disk on my Mac m1

1 Like

Experiencing this problem on my new Mac Studio M2 Ultra with MacOS Ventura 13.4 consistently. Tried to give Full Disk Access and added both ‘Agent’ and ‘Battle.net’ to my App Management within Privacy & Security but this does not help.

Battle.net shows an ‘Update’ button which throws an error after a few seconds, every time i click the ‘Update’ button a new instance of ‘Agent’ is visible in my Activity Monitor absolutely stressing my CPU to straight 100% for all instances of Agent.

Tried to disable/enable all ‘Login Items’ as well as adding Agent & Battle.net to there without any success. Decided to cancel my subscription until they fix this problem, absolutely unplayable for Mac users on Mac Ventura that needs to update their game.

Anyone else succeeding in fixing this? Please share your solution.

1 Like

Now I am getting BLZBNTAGT0000138F

I already deleted the battle.net folder in user, shared. Nothing helped.

Blizzard! What is happening?! Why can’t I install WoW anymore?

1 Like

I have installed parallells desktop (windows 11 virtual machine) for run wow. This is not perfect but it run on my mac m1 now

1 Like

Well, I don’t use parallels. Blizzard please fix this issue! I am sure it has something to do with some security stuff with Agent and macOS Ventura 13.4.1.

Update: Login without objects, and I was able to install classic! But still can’t install retail.

Update: deleted the Agent folder inside the Battle.net directory and relaunched the Battle.net.
Now Retail is downloading. Seems to fix the issue.


This is unbelievable. How can they not be more invested in this?


Deleting the Agent folder fixed it for me!


Tried everything expect using windows. Sad for all mac users, which I am for a couple of days. My mac is brand new. @blizzarddevs that’s awkard.


Hey, Blizzard
What the hell? Just’ve bought my brand new MacBook Pro M1 14, purchased the game time, was about to buy Dragonflight BUT experience the same issue described in this thread. Not only your game is not that good anymore, but also you prevent me from playing it…