MacOs (TBC Classic) cannot bind <Cmd>

Whenever I am trying to bind Cmd as in classic:

  1. Click on the bind key(any)
  2. Cmd, without even hitting second key, below text pop’s below.
  3. "Can’t bind mousewheel to actions with up and down states.

I can confirm that I have the same problem! I can use cmd in [mod:cmd] macros but that’s it.


I can also confirm that it does not work anymore since the pre-patch. It also did not work on the beta or the PTR (and it was reported on both instances). You cant use the commandkey to use already established binds and when trying to do new binds you get the error message “Cant bind mousewheel to up and down states”.

I have tried disabling all addons, repaired the client, and reinstalled the client. Issue remains.

1 Like

I ran into the same problem. Opened a ticket and I’ve been told we should leave a suggestion in the forum for it to be fixed. Doesn’t seem they recognise this as a bug though.


I can also add that this issue does not exist in Shadowlands, in both shadowlands and the classic vanlilla client it works normally, but on classic burning crusade it does not.


Echoing this one. It works in wow classic (“use cmd key as ctrl” in system keyboard options right?) or in retail as simply being able to bind cmd in keybinds without the “Cant bind mousewheel to up and down states” error.

Very frustrating as if not fixed would require new inferior keybinds for TBC classic contra retail or wow classic.


Same problem here. The CMD modifier works in macros, but it can’t be used in the key binding interface. Hoping for a fix soon.


Bumping this further. The game is currently unplayable for me being a keybind connoisseur with my druid and now half of them are disabled… It’s so frustrating, I hope it gets fixed asap.

1 Like

I found a workaround for keybindings with CMD, but it’s a bit tricky. You need to edit the following file manually: /Applications/World of Warcraft/_classic_/WTF/Account/<accountname>/

In the configuration file I replaced CTRL with META and it seems to work.

Example of a working keybind below (CMD+1):

Even with the workaround, some keybind combinations are still broken in Classic TBC, for example CMD+SHIFT+1.

Just received a response to a ticket I submitted. The issue is acknowledged as a bug and currently investigated. Fix will come in the following patches.


God bless <3

Still nothing. This is a bad joke.

wtf its august in 3 days this isnt fixd???@@!!?!?!

Please do not bump old threads