Manjaro Linux Retail WoW Crashes in loop

So a few days ago i was having crashes like every hour or so. And i thought it was gone by upgrading the wine version i was using. But now it came back hard and the game just keeps crashing.

The weird thing is however, it was fine one second, and the other i was insta crashing the client on login. I did a dungeon (the stockades) as a healer first and it went fine, then i entered mauradon and i kept crashing. I disabled all addons and was still crashing in like seconds i entered the group again.

I am a bit at a loss now to what to do. I played 2 characters to max level and into shadowlands few months ago without a single crash.

Here are some stats/specs:

Manjaro Linux kernel 5.14.18-1
Nvidia 1050 ti

Lutris settings
imgur. com /qMvpHSB

Did you checked on lutris did anyone reported it or provided a working configuration? Blizzard doesn’t support Linux so any Linux issues will not be handled by them.

Also which Nvidia driver did you used? Nvidia or nouveau?

Im using nvidia driver 495.44 and like i said, it used to work flawless some months ago, i did not change anything. Right now i changed the runner to a proton one (i think) its called lutris-ge-lol-6.13-3-x86_64 and it seems to be working again. Not sure for how long though since i thought i fixed it yesterday.

And yes i know blizz does not officially support linux, but i posted here since there are a lot of other players using linux that might ran into the same problem :wink:

I almost forgat, there is something else which is weird, i dont have enough knowledge on it myself but it might mean something. I checked the logs for when i start with lutris to start WoW and it kept saying:

MESA-INTEL: warning: Haswell Vulkan support is incomplete

Here is a larger part of the log maybe someone can see something in it (cus i cannot).

info: Game:
info: DXVK: v1.9.2-21-g2e66f45a
info: Built-in extension providers:
info: Win32 WSI
info: OpenVR
info: OpenXR
info: OpenVR: could not open registry key, status 2
info: OpenVR: Failed to locate module
info: Enabled instance extensions:
info: VK_KHR_get_surface_capabilities2
info: VK_KHR_surface
info: VK_KHR_win32_surface
MESA-INTEL: warning: Haswell Vulkan support is incomplete
info: NVIDIA GeForce GTX 1050 Ti:
info: Driver: 495.44.0
info: Vulkan: 1.2.186
info: Memory Heap[0]:
info: Size: 4096 MiB
info: Flags: 0x1
info: Memory Type[7]: Property Flags = 0x1
info: Memory Heap[1]:
info: Size: 11917 MiB
info: Flags: 0x0
info: Memory Type[0]: Property Flags = 0x0
info: Memory Type[1]: Property Flags = 0x0
info: Memory Type[2]: Property Flags = 0x0
info: Memory Type[3]: Property Flags = 0x0
info: Memory Type[4]: Property Flags = 0x0
info: Memory Type[5]: Property Flags = 0x0
info: Memory Type[6]: Property Flags = 0x0
info: Memory Type[8]: Property Flags = 0x6
info: Memory Type[9]: Property Flags = 0xe
info: Memory Heap[2]:
info: Size: 246 MiB
info: Flags: 0x1
info: Memory Type[10]: Property Flags = 0x7
info: Intel(R) HD Graphics 4600 (HSW GT2):
info: Driver: 21.2.5
info: Vulkan: 1.2.182
info: Memory Heap[0]:
info: Size: 1536 MiB
info: Flags: 0x1
info: Memory Type[0]: Property Flags = 0xf
050c:info:vkd3d_get_vk_version: vkd3d-proton - applicationVersion: 2.4.0.
050c:info:vkd3d_instance_init: vkd3d-proton - build: a19619ccbf9831f.
MESA-INTEL: warning: Haswell Vulkan support is incomplete
050c:info:vkd3d_memory_info_init_budgets: Applying resizable BAR budget to memory types: 0x0.
050c:info:vkd3d_bindless_state_get_bindless_flags: Device does not support VK_VALVE_mutable_descriptor_type.
050c:fixme:d3d12_device_caps_init_feature_options1: TotalLaneCount = 768, may be inaccurate.
MESA-INTEL: warning: Haswell Vulkan support is incomplete
MESA-INTEL: warning: Haswell Vulkan support is incomplete
MESA-INTEL: warning: Haswell Vulkan support is incomplete

It should Nvidia as the GPU, not the iGPU so that’s fine (unless it’s trying to use iGPU for some reason).

What kind of crashes do you get?
Which version of lutris runner do you use?
What version of wine + branch do u use?

In lutris, go to the wine settings of World of Warcraft. In that menu click the tab: Applications. Add wow.exe and World of Warcraft launcher.exe. Select “Windows 10” for each entry. Save. Close all applications and try again. This should solve the issue.

Ill try this, but i have another problem. i changed lutris runner and now whatever i do, even if i change it back to the settings i had, it always starts with black screen only cursor showing and music playing. need to fix this first…

I cant find what you mean in lutris. The wine settings of WoW ? where on what page does that say that. When i click configure on WoW in lutris no where i see what you saying mate. Am i looking in wrong place?

Ok i found what you were talking about. For context, i had to select World of Warcraft in Lutris and then click the button Next to “Play” and click Wine Configuration. From there i followed the steps you were saying.

It seems to have fixed the black screen at least. Not sure about the crashes but at least i can play again, was getting super frustrated.

I am now on the settings i was using before tho, which are the ge-lol-6.16.3 wine version and kept all the settings the same. lets see if it will crash again. Could you otherwise post a screenshot of your lutris settings that works for you with no crashes?

I reverted to Windows (11). I encountered crashes aswell. In addition i had some issues with playing the game and opening discord streams in a second screen. Also, I need some tools that work more stable under Windows. I just don’t have the time to be fixing all the time. And i dont want to be crashing in battleground, mythic+ or raid.