My twitch doesn't find my WoW game anymore

Is there anyway I can get some help for this?
My twitch doesn’t find my WoW on my computer, and doesn’t recognize the file when I select it.
I can’t update my addons and everything has gone very buggy since 8.1.5

1 Like

It’s Twitch’s latest update that broke something. You should be able to find your game/addons by clicking on Mods at the top of the Twitch launcher. WoW is the first on the list for me and clicking on it takes me to my list of addons. Very annoying as it used to open directly to the addon page.

1 Like

I have the same problem, but i can’t even find mods.

I searched everywhere :thinking:

I find the mods, but it says that Warcraft isn’t installed. From there I can’t do anything :frowning:

This might help Basyxqt (incoming badly drawn arrows on Twitch - you’ll have to click on the top image to see where the arrow is actually pointing …):


Imgur

Not sure this will help Feidreva though - you may have to contact Twitch if you definitely can’t see what’s showing in the pics

1 Like

Thanks for you help, unfortunately my Warcraft game is greyed and is said not to be installed on my computer.
I have tried many time to contact twitch with no success that’s why I came here.
Thanks for hearing me at least :smiley:

Did you try to locate the game again?

I had exactly the same and finally found a solution … open the twitch app - account -> log out en log back in …tada now it recognizes wow+addons

1 Like

Yes I did and still nothing :frowning:

I tried and it doesn’t do the trick for me :cry:

Thanks for all your tips.

Edit: Woops, logged out then it… restarted completely Battlenet and they are here again!!! Thanks fellow players :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.