Personal Resource Display not working

I use “Personal Resource Display” on all my characters because I like it and it works well but for some reason it doesn’t want to work on my Priest Character (The character I’m using to make this post).

I don’t remember if I had it turned on when I made the character but until recently it was turned off and now I want it turned on but no bars appear when I enter combat or at all. I tried making sure it was turned on through the Cvar command, repositioning the bars in case they somehow got anchored somewhere off screen and made sure it wasn’t completely transparent (Basically invisible) but it didn’t solve anything. Disabling addons didn’t help. I reloaded and sometimes restarted game with every attempt to solve the issue and googled a lot but the bars still weren’t appearing and nothing was helping.

As a last resort attempt I deleted the “WTF” and “Cache” folders to reset everything and besides UI getting fully reset, Personal Resource Display still isn’t working.

This might seem like an issue that is small in scale and doesn’t matter but it matters a lot to me as it has enhanced my gameplay experience a lot as it really bothered me having player and target framed there instead.

Sincerely, DehUltraEpic

From my prespective I would suggest to use Nameplates Add-on like KUI Nameplates or personal bar can also be replaced with Weak Auras. I know this could be wrong way to fix it or not too accurate but this is what I would do after all things you did (reseting addons, checking proper options in settings).

I finally solved it!

I looked at the Cvar on my other characters and found that, for some reason, “show during combat” was disabled and that’s why it wasn’t showing at all. It’s enabled now and it’s working like it should.

1 Like

BIG THANK YOU @dehultraepic.

Had the same issues with 2 old chars, where I played quite a bit with UI addons. New chars didn’t have the issue. For anyone wondering, the exact CVar is called “nameplacePersonalShowInCombat”, which cannot be overriden via default blizz UI, you need an addon like AdvancedInterfaceOptions or a macro to change these.

This settings seems to be saved per char and on Blizz servers I guess… Deleting Cache/Interface/WTF folders doesn’t work here… :frowning:

Again, thanks to finding this :smiley:

Found out just deleting the phrase SET NameplatePersonalShowInCombat “0” works. Setting it to 1 doesn’t work.

Just wanted to mention this since I had trouble finding out what to do to make it reappear :slight_smile:

thanks guys