Please help?

so i was gonna turn in the quest that gives me the legendary cape in 8.3 (dont remember the quest name) but i clicked the dragon that was supposed to fly me back to wrathion in the heart of azeroth chamber, but it started to fly underground and now whenever i try to log onto that character i get disconnected because the dragon is underground and i cant do anything about it. Tried opening a ticket but the new garbage system for tickets wont allow me to chat with a gm

Did you get disconnected when the dragon went underground?

I’ve not got that far yet so I don’t know how it works so forgive me asking silly questions but does it go to a loading screen when you go on the dragon?

it gave me a loading screen then it appeared underground in sillithus, and thats when i dc’ed

How long ago did it happen?
While I did not have the exact same issue, but a similiar which involves getting under the floor and DCed every time I attempted to log in.
In 15-20 mins, the issue fixed itself.

I sometimes had the same problems back when the flight paths were bugged.
I’d just keep logining in. Eventually it worked.
Only way I know it works. Although it wasn’t 1 on 1 same sort of issue.

it happened around 2 days ago, i’ve tried to open tickets several times, but i keep getting sent to the community threads. i waited for a couple of days to see if it was fixed by itself, but it never was

I was having a similar problem with portals but it disconnects me about 3/4 of the through loading then takes a couple of attempts to log back in and lands me back where I was so wondered if it was loading screen. Doesn’t sound like it though.

I’d keep trying like others suggest or just keep trying to open a ticket. GL I hope it fixes for you.

If it doesn’t sort itself out then figure out how to make a ticket and make a ticket. I blinked through the world one time and got the same issue and a GM had to teleport me somewhere else.

Have you tried tuning your modem/router off and on again (5min cool down) I know its standard responds to stuff but the only time I had real bad under the world stuff happen to me, it was because my modem (ancient surfboard model, 512meg days lol) and the servers were out of sync.
Gm tried for half an hour teleporting my (now deleted) nelf to the road outside stormwind, only from me (and a poor guard NPC) to be still falling thru the floor. Eventually it was fixed by my modem being fully unplugged for about 5mins to clear any residual power and then coming back.

Did any of you try logging in on another character first? Sometimes that resets things.

Had similar issue. Third solution from here worked for me.

https://eu.battle.net/support/en/article/10581
2 Likes

I remember something similar that happened at the start of BFA, if I was grouped with people for IEs and I was on a flight path when we entered it would bug after the IE and just end up with me flying in a straight line even going through terrain and the ground. A couple of disconnects later and it would allow me to do stuff again.

  • Uninstall all add-ons, ( if the problem still persists)
  • Repair game, ( if it’s still persists)
  • Switch to windows mode,( if it’s doesn’t work at all)

Contact blizzard.

You will keep dcing on that char when you try to log in.

You cant also use emergency help hearthstone from help menu.

What you can do is write ticket from forum or in-game. GM will port you out from there but you have to wait meantime.

This. So much this.
I had for ages now that on my main everytime I use the Darkshore portal in Boralus I fall trough the world and DC. Logging in and again falling and DC.
What helps is using the 3rd option from the link that was posted.

This moves your character to Westfall graveyard and you can resume what you where doing before. Should solve the issue and take like 1 min to fix.
No need to wait for a ticket respone or GM to help.

2 Likes

Wow. I didn’t know there was now a self-unstick service option

Here it is:
https://eu.battle.net/support/en/help/wf/wow/197/834/