Power of the primus quest bugged

Same Issue for me and I can’t even open a god damn ticket. If I go ingame it redirects me to the website and when im on the website they tell me to do it ingame. What gives. So frustrating, can’t even get my Soulbind.

hi das selbe Problem habe ich auch sehe das Rufzeichen kann aber die quest nicht Annehmen

I’m beginning to feel that they don’t actually care. This issue has been ongoing since December if you look back at previous posts.

I’ve had to go Kyrian - Necrolords (bugged) now to Night Fae as I’d be locked out for a reset going back.

This system is extremely flawed and gamebreaking in my opinion. I suppose they’re more concerned about churning out a terrible looking store mount as opposed to fixing a solid game feature.

If the ticket answer didn’t solve the problem, reopen the ticket and explain the exact problem clearly and simply. Link the blue post in this thread telling you to make a ticket.

same EU76496670

Hi everyone and thanks for the reports!

We’ve identified the issue that’s causing this and currently working on a hotfix.

Attempted manual fixes to issues like this by Game Masters are always risky and have the potential to cause other problems, so for those affected I’d recommend waiting for the hotfix rather than opening (or re-opening) tickets.

We’ll try to keep the thread updated with any news, and thank you for your patience for now!


How long are we looking at? :slight_smile:

1 Like

Is there an estimate on when this is coming? days? weeks?

1 Like

Funny, now explain why all the GMs have tried to put the blame for not doing things properly on the people, because this was a terrible service provided, I got blamed that I am basically blind and stupid for not doing previous quest, etc, etc, abhorrent attitude - I am dealing with this issue for 3 days only to be berated by incompetent customer support. Disgusting.

1 Like

When it will be fixed ? I change because of logs pression and there it is …


Any ETA?

Finally fixed

It’s GM Verdaniih here, I hope you’re doing well today!

I’ve found your ticket and managed to have a look over it, it seems you had some problems with the quest Power of the Primus, I know that must be really frustrating for you.

After checking everything out now there is no need to worry because I have fixed this for you and set you on the next step in the quest chain which is waiting to be handed in when you are next online.

I really hope that this has cleared things up for you and that the rest of your day is awesome! :slight_smile:

1 Like

Fixed too, Unfortunately that will take some time to fix from their side so I have corrected it for you ingame so you can continue with the Covenant quest chain.
I hope you get your help too :slight_smile:

Meanwhile I am getting a link to wowhead articles, for reseting ui and changing covenants… lovely


+1 Another satisfied customer.

Probably only “chosen ones” got manual help from gm to complete quest, others have to wait for a hotfix…

more likely there are a few employes who have gone through training and are actually doing their job and then there are others, who are there to do minimal work for the money

1 Like

I received the below reply from a GM. As I’m already at chapter 5/9 (with still no soulbinds whatsoever) purely by grinding heroics / RBGs etc. this reply did not help me at all, but there may be someone who can try it:

"Sorry for the trouble you’re having with these quests!

If you have picked up Anima is Strength and/or Bringing It All Together but are not able to see Arkadia Moa to turn the quests in, complete Chapter 1 of the Necrolord Covenant questline to correct your phasing.

If you have left the Necrolord Covenant questline, you should abandon these quests, as you will not be able to complete them."

For all the handicapped characters out there… I just figured you can pet Dreadfang about 22737 times until you receive a reply to your ticket. At least it’s something relaxing and meaningful to spend your time with :slight_smile:

I’m also bugged! :frowning: