SOD No longer loads

Hi, I’m not exactly sure what caused this but in the last 3 days I’ve no longer been able to load season of discovery.

On pressing ‘play’ I now get the window appear for the game but it’s just white and within 5 seconds states ‘Not responding’ on the window and in the task manager.

I’ve already tried searching online and doing all the regular suggestions for fixes:

  • add in additional commands for -d3d11 and -d3d11legacy (just in case)
  • I’ve done repairs of the software
  • I’ve done a full re-install of the game
  • I’ve also deleted Cache and all other blizz/wow folders in %ProgramData%

Any further suggestions greatly appreciated :slight_smile:

Hey. Me and other people have got the same problem. Also in the US people are reporting it. Check out my thread here:

Tried talking to customer support but I’ve received the “Why don’t you try to update your drivers” response.

Forgot to mention I have also updated my drivers the AMD software is showing nothing left to update with. I’ve also left the software running for 3 hours with still no progress.

Check my thread. Do you have sophos / hitman pro installed?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.