Spell delay and input lag

Hi,

I’ve recently started playing shadowlands and got to max level but one thing is stopping me from recommending it to friends.

The lag in zones. Is anyone else experiencing what can only be described as input lag when doing tasks like world quests?

I play a fury warrior so it’s a fairly fast paced spec. I’ll hit rampage when I have a full rage and it will cast. I see the global cool down timer disappear and I’ll be mashing bloodthirst but my ability will cast and animation will trigger anywhere from 0.2 to half a second after I have hit the button. Feels super bad. Sometimes combat can get so desynced I’m not sure what’s going to happen next.

Interestingly this happens far less in dungeons.

I’ve tried experimenting with spell queue window values but no luck.

I’ve updated and then removed any add ons and no luck.

All drivers up to date.

I’m on a wired fibre to the premises connection and sit around 16-20 ping. No packet loss.

Is it just me? The game feels super bad to play and makes me not want to play when it’s happening.

Thanks

Hi Heyawar!

So the first thing we’d recommend in this case is a full UI Reset to eliminate any problems there, which often can be the source of issues. There’s a guide to that here:

Yours,

Arythwinn

Hi Arythwinn

Thanks for the response.

I followed the link and did as you suggested and on game launch it generated new folders.

Unfortunately the issue persists. I’m hitting spells and the animation, cooldown bar is desynced from my button presses. The gap between rampage finishing, the global cooldown ending and me hitting execute was so delayed.

Any other ideas? I have 14ms home latency, 15ms world latency so it should be pretty quick!

1 Like

I have exactly the same problem.

This doesn’t happen with my Frost DK or Havoc DH. The problem only occurs with the Fury Warrior.

I even reinstalled my WoW because of this, but the problem persists.

17ms Home latency and 21 World latency 56-60 FPS. So far I haven’t found a solution to this.

Sorry wrong Character

Hi, it helped me turn off the blizzard app. GL HF

2 Likes

Same here, started happening weeks before the “guild and guild chat not showing ingame” issue started.

Yesterday for some reason after they fixed guild/guild chat, i haven’t had a single action bars input lag in m+ dungeons or dungeons and raids in general (complete action bars/spells input lag, but chat worked fine… they said i was moving tho, moonwalking on place).

Today though, i started getting input lag like crazy again when i was doing mythic+.

Whenever i /reload, the issue persists. Whenever I quit the game completely and restart it from the client, the issue goes away and after less than a minute it happens again.

Sometimes it seems to happen on the loading screen and it gets stuck.

I’m using a separate wifi pcie card right now because that’s the only way I can connect at the moment.

My wifi card is the one that comes with the motherboard asus rog maximus vi extreme - the mpcie combo thingy that has wifi, bluetooth, and 2242 m.2 ssd slot on it. My router is the TL-WR841N and I connected it to an alcatel LINK HUB 4g router (HH71_IP_02.00_01 modem version) that i turned all wireless signals off on, and I set it to only work as a 4g to ETHERNET “modem” so there’s no much strain or signal interference.

From this 4g router i connected an ethernet cable all the way to the tp link router and they are I’d say 16 feet apart. The tp link router does the routing, wired, and wireless.

Had the same issue as all of the above for no apparent reason.

This fixed it for me, thank you very much!