The problem with containing a death loa

This quest is bugged the Zel’han the Summoner mob is evading our attacks for like 3-4 hours now its not possible to kill him to continue campaign quest.

3 Likes

Edit2: Changing shards does seems to help! (Was my original post but did not include WM)

Can confirm . Server:Nordrassil
Showed up and he was already bugged, not possible to reset

It’s not possible to reset him.

2 Likes

Shadowsong here and even getting invited to a group on a different server does nothing, can a GM please do something about this its rather frustrating waiting and nothing is happening people would like to continue with the game

3 Likes

I’ve managed to complete by turning on War Mode and going back he was killable there.

1 Like

Thanks for the info - will try that later

confirmed turning on war mode worked but shouldn’t have too really…

Can also confirm turning WM on worked for me too

Hi guys!

So it does sound like this is not always working properly, and please do report this bug per the guide:

However, as others have noted, changing shard does seem to resolve this, which you can do by toggling your War Mode or joining a group on another shard.

Yours,

Arythwinn

1 Like

he is still broken just evading, im on Azune. they say he has been broken all day.

Doomhammer here, this is also going on here still at this moment. Relogd a few times but nothing changes, a lot of people are waiting

1 Like

Yep, still broken and I’m on Aszune too. Very annoying. You should not have to resort to enabling war mode in or der to kill Zel’han. There are a lot of horde around so … that’s a bad idea!

damn blizz

fix it

still bugged on EU Draenor, pls fix this

Thanks everyone for reporting this. Please review the previous response on how this can be reported to our developers.

Hi, the quest, which is part of the Night Fae campaign, is unfinishable due to the fact that the NPC for the quest has been evade bugged for more than a day now, not sure if it is on my server/shard only though. The server is stormrage. Thank you.