To those with stuttering, This was a fix for me:

I have set my pagefile to my SSD. Windows automaticly setted it to my HDD (Which I used for storage mainly).

I have not had stuttering and can do anything else (Such as alt tabbing without problem).

Windows can set the paging file on a slow or old HDD if you have multiple disks. This can cause Huge Stuttering if that slow or old HDD drive can’t load assets fast enough.

Make sure you have at least 20/30GB spare on your SSD First!

In the Windows 10 Start menu type ’ Perf ’ and Select ’ Adjust appearance and performance of windows’ .

Go to the advanced tab, and go to Virtual Memory , click ’ Change

At the top, untick 'Automatically manage paging file size for all drives

Select each drive individually that is NOT a SSD and select ’ No Paging File ’ and Press ’ Set

Set the SSD Drives to ’ System Managed Size ’ (This allows windows to pick a size) and Press ’ Set

Click ’ OK ’ on the window, and the previous window.

Restart the PC

Try the Game!

My storage drive is a 1 tb 5200 RPM hdd.

Keep about 20-30 gig free for page file on SSD.


Thanks a lot mate this was a fix for me who got an old HDD, now it’s smooth and there’s no stutter at all.