Uuna World Tour bugged

I did complete all requirements for Uuna until the World Tour, but now when i go to Gate of the Setting Sun, she does nothing, i did try with WM on/off different character, both Pandaria and BFA version, but she just runs around. I think i ran every inch of the ground there.


Same for me.

I sent an ingame ticket reporting the situation and hopefully will get more than just a automated response.

Will update when I have a reply. :heart:

1 Like

I’m having the exact same issue. I have opened a ticket and received a reply. It was a very generic response, it feels like the team didn’t even read my question. I have sent a follow-up as I have spent over an hour running around the gates trying to get her dialog. I have found simliar issues on US forum.

Will blizzard please help as ive attempted everything… all addons off, catch clear etc.


I also got the same generic response but reopened my ticket and further pressed this issue.

I’ve seen posts from FEBRUARY reporting this situation and still no hotfix or blue post…

1 Like

Having exactly same problem. Out of ideas to try to make this happen. Nothing seem to help.

1 Like

Same issue. Been at the gate for hours and nothing is happening.

Having the same issue. Ran around in circles for half an hour with no luck. Somebody else from my server said he had been trying for 5 days with no luck.

1 Like

Same here and it’s really annoying, you can’t even do secrets anymore without bugs.

Still the same after the reset and changing the corruption zone. I had hopes it will be related to the Ny’alotha raid location, but not.

Sad story.

1 Like

Still in effect as of 19th of May. So annoying.

Still not working for me (1st June 2020). I put a ticket in but received a template response. Feel a bit mean about my reply but I’m super disappointed about this :frowning: hopefully we get a fix soon.

Hi everyone,
I can confirm it’s still ongoing on the 7th of June. I wanted to do something fun in my weekend qnd collect Baa’l, but to do so, I also needed Uuna. So here I am, Ready to get Baa’l, everything found. Uuna resqued from the Darkness and ready to do the World Tour, just to get stuck on the first part.
Blizzard is well aware of the issue, because they locked the other forum post with this issue just 2 hours ago.
I believe so many people filled in bug reports that they just get thrown in the trash atm because they’re too focussed on getting Shadowlands out.
I’m willing to make a ticket as well, but I doubt it’ll get any other reply than the standard F-u like everyone else got.

Having the exact same problem too guys… it’s a shame that this bug is still up! I mean it’s one of the secrets to unlock 2 other big secrets in the game!

Blizzard, shame on you, really!

Is there any update on this pls Blizz?

I wish they would fix it soon, been so long waiting to complete this.

Just worked for me today!!! (from a solution I saw somewhere on these forums)
(I was WM OFF but I don t think it matters)

  1. Switch to Old Pandaria (Not current N’zoth version)

  2. Go to the gate. Stand in the middle next to the entrance from Vale (Coords 9.59)

  3. Dismount and make sure Uuna is not summoned already

  4. Logout / Exit Game

  5. Login and Summon Uuna.

  6. Enjoy the chat and hope it doesn t get stuck somewhere else.!!!

1 Like

Confirmed! This worked for me today!
26.06 Argent Dawn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.