Warlock class hall "A Greater Arsenal" quest bugged

So I tried to get my artifact weapons and for some reason I’ve got all of the weapons without doing the last artifact quest. Now the quest is still open but when it asks to pick an artifact nothing happens. I’ve tried almost everything from switching specs, to restarting the game or abandoning the quest but nothing seems to work.

2 Likes

Currently having the exact same problem. Calydus even gives me two options of “Let me select my artifact”. the first option then gives me the option to pick demonology artifact, but nothing happens after that.

The other option doesn’t do anything at all.

Opened a ticket, and a Blizzard employee didn’t wanna do anything about it, other than telling me to file a bug report…

Hi Warlocks!

So this does indeed appear to be an issue that is cropping up now and again, but we should be able to fix it. Please do re-open an issue (remembering to mention what the name and realm of the character is if you are not doing so in-game via that character) as per this guide:

Yours,

Arythwinn

Please do not bump older threads.