Warlock Legion Legendary quest chain bug

Not sure if anyone else has experienced this, but there seems to be a fairly major bug with the warlock class quest chain in Legion. Basically, I followed the questline to get all 3 warlock spec legendaries, then went back to Dreadscar Rift, and Calydus had the same quest again (A Greater Arsenal). Upon speaking to him, I immediately noticed that his dialogue options included the option to choose an artifact (as well as the option to start ‘A Greater Arsenal’). I clicked the ‘choose artifact’ option, and the conversation closed. I then spoke to him again, chose to start A Greater Arsenal, and a second ‘choose artifact’ option appeared below the first. I clicked that, and it prompted me to choose the demonology legendary to pursue, so I did that, and once again, the conversation closed, with the Quest log still showing ‘0/1 Artifact chosen’. Is anyone able to shed light on this please as I’m unable to continue the questline at the moment. Thanks in advance :slight_smile:


Legit have this exact same issue with my lock, very frustrating. I have tried dropping the quest and picking it up again but still the same. Whats weirder is that I already have the artifact.

Maybe I should delete the artifact and try?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.