Why are all realm populations incompatible for me?

Every realm is red for me and the populations are incompatible? I was playing fine earlier today. I get instant disconnected when trying to choose the realm I play on.

Launcher will not let me scan & repair the game either?


Solved it. Apparently idiot10 decided to keep 3 different instances of WoW running and thereby preventing any updates from happening.

1 Like

same for me

I’ve go tthis problem right now, can’t login to any server as they all show incompatible and highlighted red. If i click on a server and try login in i get booted back to the login screen with the DC error code we have all become to see on a regular basis since last patch.

I got a patch/update when i logged off last night, can only assume that’s the culprit.

Solved now. After opening and closing Bnet several times, restarting the PC and still having no luck i went off to do something else, then after about 15 mins BNet decided to start downoading another patch.

So obviously some weird delay in retrieving the patch, so client version differed from server version, thus incompitable. I did not have multiple instances of wow or BNet running like the OP.

Hi there,

Glad to hear it worked out already!

Just to note in case anyone else runs into this, more information and common solutions can be found here: