WoW won't launch from launcher

I try to open wow in launcher, but when i click “Play” nothing happens, it appears in task manager, but nothing happens. Blizzard Launcher says it’s Playing World of Warcraft, but the game hasn’t launch, next to that, I’m able to click the ‘play’ button over and over. The mouswheel will come over in the screen, but then nothing will happen.


Welcome to the club. I tried everything, and I mean EVERYTHING, on the support page as well as the various tidbits of advice from God knows how many different people on this and other forums.

“This will work, try it!”. Cool story, bro. Or, it would be a cool story, if it worked, which it literally didn’t. I let the idea of making my own thread about the issue ferment for a couple of days and eventually figured that I just didn’t want to bother.

I guess the Blizz glory days are long gone. This stuff didn’t use to happen, and my hardware/software is perfectly suited for this game. I’m just waiting for a Bluesie to show up and tell either you or me to try the non-functional official support advice, so my chuckling can commence. Hey, a good chuckle isn’t anything to sneer at, right?

1 Like

I am getting the same issue, I click play and it says loading, then it goes back to play…
WoW appears in the task manager but as not responding…

I have tried all the support ideas but nothing works… I am running out of ideas and it is very frustrating! All I want to do is log on and play, I have not been able to get in the last 2 days and I last played on Saturday the 2nd.


Please read Unable to open WoW. Black screen and an infinite mouse loader followed by unresponsive error - #23 by Jacaranda-chaos-bolt and the link inside it to the us forum.

Are you running sophos / hitman pro?

this was my reply from Blizz
A Game Master resolved your ticket, and left the following response:


Thank you for reaching out and taking the time to follow the provided steps. I’m sorry they didn’t resolve the issue you’re experiencing. It’s frustrating when troubleshooting steps don’t fix a problem.

Since you’ve exhausted the steps available through customer support, the next best course is to seek assistance from the broader community through forums or consult with a local tech expert. Sometimes, the issue might require more specialized knowledge or diagnostics tools that aren’t readily available through our standard support channels.

Contact Activision Support if you’re experiencing issues with playing/launching any Call of Duty game.

Our forums can be a great resource, as knowledgeable community members often encounter similar issues and can offer helpful advice or solutions.

Once again, I apologize for any inconvenience this has caused you.

I’ve just resolved the issue on my PC I completely uninstalled SOPHOS Endpoint… Now all is back to normal…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.