Disconnessione server codice 1016

Salve avrei veramente bisogno di un aiuto.
da circa 2 mesi ho cambiato gestore telefonico passando da Vodafone a Fastweb con relativa sostituzione del router, prima capitava sporadicamente che la linea internet cadesse dandomi il codice 1016, da quando sono passato a Fastweb la cosa è diventata veramente indecente perché ogni 5/6 min. circa cade internet e sta diventando veramente snervante.
il router è posizionato al piano superiore mentre il pc è a piano terra, per oviare a possibili cali di rete ho comprato un wifi extender e sono collegato a quello.
quando navigo in internet normalmente non ho nessun problema, appena mi collego a diablo3 iniziano i problemi.
Qualcuno ha qualche consiglio per poter risolvere questo problema?
vi ringrazio e vi saluto.

Un cavo ethernet.

Miracoli non possono fare gli extender.

Si vede che rispetto a prima,la potenza del segnale che manda il router e più debole,altrimenti la linea non cade.

Comunque sia giocare in Wi-Fi a giochi del genere non è cosa. Io avevo lo stesso problema ma a piano inverso,morale della favola cavo e via.

Ciao Jonny88 ho seguito il tuo consiglio e ho collegato il pc al router con un cavo ethernet facendo un po di fatica per portarlo da un piano all’altro, ma purtroppo il problema persiste ancora, stesso codice (1016) dopo circa 5/6 min che sono collegato con Diablo3, ho fatto uno speedtest e in download arriva a 30Mbs, si scollega proprio il gioco, quello che non capisco è il fatto che se uso il pc per navigare in internet o per vedere dei video su YouTube non ho nessun problema ne con il cavo ne senza, il problena inizia appena entro in Battlenet/Diablo3.
Ho letto su il forum che potrebbe essere un problema di porte del pc, ho seguito anche quelle indicazioni ma niente da fare, appena inizio dopo un po cade tutto e si scollega dal server per poi riconnettersi immediatamente appena torna alla schermata iniziale per far ripartire il gioco.

Prova a diminuire la qualità dello schermo in diablo3

Ho googlato e mi è uscita questa risposta. È vecchia di due anni, ma tentar non nuoce (anche se non me ne intendo molto di queste cose).

“If the troubleshooting info that we offer doesn’t help to resolve this and you’re running If running IPv6, I recommend contacting your ISP to have them change protocol to IPv4.”

Ciao Keldor,

L’errore 1016 può essere causato da diversi problemi di connessione specialmente se il tuo gestore indirizza la tua connessione attraverso nodi della rete congestionati quando cerchi di raggiungere i server di Diablo III.

Vedo comunque che stai usando IPv6 quindi il suggerimento di Heartblow è molto valido e dovresti contattare il tuo gestore internet per farti cambiare protocollo passando ad IPv4

Detto questo ci sono altre soluzioni che puoi provare per prima cosa segui tutti i passi in questa guida. Se i primi 5 non risolvono segui anche i Passaggi Avanzati nella stessa pagina.

Se il problema persiste sarebbe utile vedere un tuo tracciato di connessione verso i server di Diablo III tramite WinMTR puoi incollare il risultato sul sito Pastebin e rispondere qui mettendo il collegamento con l’opzione Testo preformattato ( simbolo </> )

Ciao a tutti, grazie mille per i vostri consigli.
Li ho seguiti tutti uno x uno, purtroppo non riuscendo a risolvere il problema.
L’unica soluzione che ho trovato è stata quella di formattare il PC e reinstallare tutto da zero, ora il problema sembra essere sparito, in una giornata mi ha dato l’errore 1016 una volta sola. Prima era una cosa indecente, evidentemente era un errore di sistema di windows. Cmq grazie x le vostre risposte e consigli e per aver dedicato un po’ del vostro tempo x rispondermi.

1 "Mi piace"

Bè, potevi seguire il consiglio dato sopra e postare il tuo tracciato di connessione, magari si capiva con esattezza il problema e ti saresti risparmiato l’intera formattazione, ma è bello sapere si sia risolto almeno in parte.